System.UnauthorizedAccessException: Access to the path '7996'... What is this?

I’m in the process of learning how to make plugins. So beginning with the tutorials online I’ve hit a road block.

When re-building the project

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(42,5): error MSB3075: The command ““C:\apps\Epic Games\4.11\Engine\Build\BatchFiles\Rebuild.bat” {some .cs file} Win64 Development “D:\Users…\Desktop…uproject” -waitmutex” exited with code 5. Please verify that you have sufficient rights to run this command.

When building the project

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(37,5): error MSB3073: The command ““C:\apps\Epic Games\4.11\Engine\Build\BatchFiles\Build.bat” {some .cs file} Win64 Development “D:\Users…\Desktop…uproject” -waitmutex” exited with code -1.

Done so far:

  • Reinstalled Unreal Engine (4.11.2)
  • Reset Visual Studio (2015) to default settings
  • Ran Unreal Engine and Visual Studio with admin rights

How to fix this error?

1 Like

I managed to solve this issue and thought I would post it.

Steps:

  1. Go to C:\apps
  2. Right click “Epic Games”
  3. Under the General tab, unselect “Read-only”
  4. Hit apply
  5. Open the visual studio project and build/rebuild

Hope it helps

1 Like

It worked for me…
https://answers.unrealengine.com/questions/295689/unreal-engine-49-cant-build-source-when-editor-is.html

This did the trick for me, somehow after adding the source to my perforce folder, the folder changed to Read only.

So just select your source folder => Right Click => Properties => Unselect read only => Build

2 Likes

Thanks for the tip!
In may case, it worked after unchecking the read-only from the Binaries folder.

1 Like

Thanks, unticking Binaries folder works.