"/system/bin/sh: syntax error: unexpected '(' " when launching game in mobile.

I’m trying to launch my UE5 game on my Android, but it keeps saying “/system/bin/sh: syntax error: unexpected ‘(’” in the Unreal Output Log. Also, the game appears to not be loading, because the screen is completely black and I can’t hear anything… Can someone help me please?

1 Like

In the error log you should be able to find something more than what you see there. Have you been able to package and launch a default game project on your phone?

Every time I tried to package, it took more than 9 hours and I ended up giving up. I’m trying to launch the game using the Project Launcher, but it keeps loading for hours. I really don’t know what to do

I opened the Device Output Log and found these errors & warnings:

[GameActivity] Warning: hardware does not match ro.soc.model, assuming hardware is correct
Fatal error: [File:./Runtime/CookOnTheFly/Private/CookOnTheFlyServerConnection.cpp] [Line: 52]

9 hours? How big is the game size wise? What hardware are you running on your PC, it should at least be: Hardware and Software Specifications for Unreal Engine | Unreal Engine 5.0 Documentation

The game isn’t that big (only 1GB), that’s why I ended up giving up. And, yes. My PC has the recommended settings. I’m just having this problem when packaging/launching for Android… When I package to Windows everything works perfectly (the game has two different versions for each of the operational systems, I’m not that dumb haha :sweat_smile:)

I read the documentation you sent again and I think changing the Lumen lights to another type might help… I’ll try to package these changes and come back here tomorrow to let you know if it worked.

any luck? i have the same problem

trying to package since 7AM… still no luck

i switched to 5.1 after doing some research to see if its smoother to work with the next step would be 4.27 but trying to keep it closer to the newer versions if possible ive gone through a million different videos and im about to test it on the phone now.

it worked?

unfortunately no im back to the same scenario with syntax error

I tried completely reseting the files before sdk and other setting changes in case anything was causing conflicts and it still resulted into the same thing

all i could really find out its a typo in code but my problem is i only did blueprints. been at it the whole day i guess im going to figure out where the hell the code is. wasnt expecting this much trouble

Something else is completely wrong if it takes 9 hours to package a 1 GB file. Can you package a completely new project?

yes, I can package the same project for windows. Only the android version takes that long

No, I mean can you package a new project for your mobile device? It’s a good idea to test that out. If you can’t then it’s likely an Android Studio or phone issue.

oh, wait a minute. I’ll try right now

neither the new project launched correctly. it keeps loading forever

Alright, this is indicating that you are having issues with the installation of Android Studio. Have you restarted your PC since the Android Studio installation?

Follow this, and don’t be clever and change the settings from his: https://youtu.be/OAYEpiTgeXI?si=yv0U6p9TrVGnGRQZ. Secondarily, install Android Studio to a path that doesn’t contain a space.
:x: C:\Programs\This Folder With Space\CantBeUsed
:white_check_mark: C:\Programs\ThisFolderWithSpace\CanBeUsed

Also set your Phone to Developer Mode and allow USB connection to install application to the phone.