Download

Swimmable water

I’m new to UE4, but I have spent the last 3 days trying to make swimmable water that looks good. I have followed different YT videos and tutorials but mine never turns out the same way as there’s.
I’m trying to make water that has the effects of swimming - post-processing effects and buoyancy, along with proper movement.
My snags have included unable to move through shape_plane, can’t move through the water (I added key bindings but I’m looking for pitch movement), light doesn’t pass through water, can’t make water transparent, etc.

If anyone has any documents put together, I would greatly, greatly appreciate the assistance.

I’ve tried this page: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums, but he doesn’t say anything about the post-processing effects, just to put the box in there. Also, the water isn’t transparent and I can walk on it…

Thanks!

the problem with the plane -> turn off the collision (double click onto the static mesh in the content browser - collision - remove collision)
transparent water -> https://www.youtube.com/watch?v=KPmRV1Z9ikY (I think you just have to delete the part with the depth fade)
post process effect -> the best way is to just play around with the settings till you get a good result, because there are not “perfect” values :slight_smile:

Thanks for the quick response, fighter.
I have collision turned off on the plane and I still just walk on top of it. The only other setting I’ve touched is “use two-sided light” and the lake material.

  1. which template do you use? (3rd person bp template,…)
  2. have you enabled “physic on contact”, water volume + check your value at “Fluid Friction” (choose a value around 20-30)
  3. are you 100% sure that you disabled the collision of the plane? -> check if you can see a collision in the static mesh editor or set the collision mode to “none” (in the details)
  4. the lake material in the starter content doesnt use transparency -> so you can’t see through it. Take a look at the tutorial that I mentioned above :slight_smile:

collision.jpg

  1. FPS
  2. Yes. All three have been set.
  3. Please see attached image. Is that what you’re talking about?
  4. Will do. :slight_smile:

Thanks!

I figured it out. I had to customize the collision settings to allow the player to pass through. The shape plane was defaulted to “block all”.
collision2.jpg

Thanks for your help! I will tackle transparency now.

Check out this thread. There is some info about transparency as well as lots of other cool stuff: https://forums.unrealengine.com/showthread.php?47316-Ocean-Storm-WIP&highlight=water