Download

SwarmAgent seems to be hampered by cpu's with a high core count?

When trying to render the lightmass for my project tonight, i found the lightmass calculations were still busy multiple hours after i started it,
So when i went to check up the progress in the swarm agent program.
Then I discovered that at around 40% of the “elapsed time” diagram, Out of my 16 cores, 8 cores finished their job with only 8 cores continuing, 20 minutes later 5 other jobs ended. Since then the bulk of the render time, swarm has just used the remainder 3 cores for the rest of the build.
Even a few hours later my CPU is chugging away at 18.75% load of it’s full calculating power.
RSbDcvx.png

Is there a way that these kinds of jobs are better distributed over multiple cores, as the render times on my project now seem unnecessarily long.

This means that there are no more jobs to distribute to the cores that have finished. And you are left with the last few jobs. Lightmass distributes work on a per-staticmesh basis as far as I know.
I suggest you look at the lighting build stats once it’s finished. You can see what staticmeshes have taken the longest to calculate. These will most likely be your bottleneck.
If you are working with multiple swarm agents on different PCs and there are few staticmeshes in the scene, a 16 core PC with a low core clock such as 2.5Ghz might be ironically a bottleneck compared to 8 core 4.0Ghz CPUs.

Like Norman3D said, look and see which objects were hogging all the time. Your light build can only be as short as your biggest object calculation. So if you have a massive object with a 4k lightmap, you might consider breaking it down further into multiple meshes and smaller lightmaps to be divvied up.

where can you see how long each object took to render?

Lightmass can’t break lightmaps up over multiple cores - so you’re usually limited to the largest object!

Likely targets are large meshes or huge lightmaps. I’ve also found that if you have a lightmap in the level that’s larger than the maximum lightmap size in World Settings, you can also get a big hit on time too.