Swarm, whats the big secret?

Anybody mind telling what one has to do to get Swarm to bloody work across all the agents on a home network. It doesn’t matter what I’ve tried, the co-ordinator sees the agents, they list as available and assigned, but after sending a LightBuild job, only the host machine will pick it up. They never show as working.

Trawling through the Unreal threads and other forums it seems obvious I’m not the only one that is suffering in trying to get this setup and it’s quickly becoming a waste of ones precious life. C’mon…why is this so difficult?

I use 3dsMax with Backburner and have had my home network of 4 pc’s setup for sometime, I’d like to think I’ve ironed out all the issues I’ve experienced in the past, but Swarm is doing my head in, and I don’t think Unreal’s documentation on the setup gives much away. I understand everyone has different setups at home, but if pc’s and other software talk and communicate, why the hell doesn’t Swarm just work. I’ve read the passage about Agents being too busy to handle a job, but this is a home network, they’re sitting there practically idle except for some background diagnostics.

Typically, like most, (and having already done my research on the swarm setup), I have the SwarmAgent.exe’s residing in shared folders on the clients, the job folder on the host is in a shared accessible folder, all files are not password protected within my homegroup, all computers can see each other, and I normally rdp from my workstation to the other pc’s in my network. Never a problem.

I’ve enabled permissions within the firewall and manually opened up ports 8000-8010 as I read somewhere before. Nice green ticks everywhere.

I’ve set consistent naming within the Distribution Settings Tab AGN and ARAG are both HomeFarm and ARAN is left at the default RENDER*. I’ve set the timeouts to 0 to override anything too short. My host name is Coolermaster, again consistent across the agents, though I have tried the host pc, IPV4 strings as well without any luck. In fact it doesn’t matter what I do, the Co-ordinator sees the agents, but they don’t receive the job. I’m sending a small scene, just an interior shell with textures and HDRI, nothing too heavy and lightMass switched to production to give it time to chew it over. Surely big enough for the agents to respond?

The only thing I can think of is to do with where the Unreal project/game folder is residing, as I don’t quite understand this as just being called ‘Game’ root directory, and not listed on any type of drive. My pc is setup like this, my Data folder with all my work and jobs, I call X, it’s basically one big partition on the drive, I have that drive shared, which can be accessed through the Network and I also have it mapped as Z, which is primarily for maps when rendering within 3dsMax. I make sure to remap everything to Z for network rendering within Max.

When I first created an Unreal level by importing the datasmith file, should I have imported it via Network, or Z, rather than locally off the X drive.? And how can I change this to remap all the files and assets. Really can’t think of anything else to try, and done plenty of searching so figured I’d just ask. Thanks.