Download

swarm not working correctly

Hi all, This is driving me crazy and I have spent hours on this and cant figure out why this doesn’t work. I have a total of 3 machines. A,B,C.

A is my main machine that I am running UE on and doing my builds on. B and C are my agents. I have them setup correctly, they ping each other and show up in the Coordinator window. See attch jpgs

The issue is the IP address for machine A is not 127.0.0.1 thats what shows up in the coordinator window. When I go to build I only get machine A to show up.

Why is the ip address not showing as I have set it up? How do I change the ip to show up correctly in the Coordinator window?

As a side note, when I work in 3ds max and vray and render across the network all the machines work fine. I dont have any issues at all.

Any help would be appreciated.

Thx

Alex

127.0.0.1 is the local host ip - a special address used to represent your own device. It just means that it’s the PC the coordinator is running on, nothing to worry about.

For AllowedRemoteAgentNames, I just put an asterisk instead of the IPs. Are you using the same settings on the two agent PCs?

Thanks for that explanation.
Yes I am using the same settings on the 2 agents. I have tried IP’s and the computer names and either way its not working.

Have you tried putting a * in AllowedRemoteAgentNames instead? On all 3 PCs.

Yes I have tried that as well. Its just really odd.