Swarm networking broken by having VirtualBox installed

Here’s the setup: I have a swarm agent and the coordinator running on my workstation with the editor. I have an agent running on a few other computers on the LAN as well. Everything works fine, they share the load as expected.

But upon installing VirtualBox on the main workstation, now all of the remote agents no longer take any work and it all gets done on the workstation.
I looked at the Coordinator and see that all of the Agents are still connected just fine. But the Agent on the workstation is listed with the wrong IP.
It turns out VirtualBox installs a new network adapter to route between the VM and host, so Swarm on the workstation is using that to discover its IP, a different one from what it has on the LAN.
On the remote Agents, I can see that it connects to the coordinator just fine (after all the agent config is still correct) but upon starting a light build it spams the log with errors “Could not ping [workstation] at [wrong IP] to verify connection” and takes no work.

I fixed it by disabling the virtual network adapter, but I do need it for other things and the driver for it locks up my system for a while every time I enable or disable it, so it is an annoying process to switch betwee UE4 and my other work

Hey aeheathc,

This seems to be directly related to VirtualBox because Swarm Agent works fine without it. I went to their website and this was mentioned on the front page.

“VirtualBox is being actively developed with frequent releases and has an ever growing list of features, supported guest operating systems and platforms it runs on. VirtualBox is a community effort backed by a dedicated company: everyone is encouraged to contribute while Oracle ensures the product always meets professional quality criteria.”

Try contacting their support as well to see if there is a workaround for VirtualBox creating a new network adapter. Let me know if you discover anything new, and I will continue to investigate on this end as well.

Thank you,

Andrew Hurley

I found some useful information on the website that you also might want to take a look at and consider when using VirtualBox with Swarm Agent.

**Note : ** Choose this setting carefully! The memory you give to the VM will not be available to your host OS while the VM is running, so do not specify more than you can spare. For example, if your host machine has 1 GB of RAM and you enter 512 MB as the amount of RAM for a particular virtual machine, while that VM is running, you will only have 512 MB left for all the other software on your host. If you run two VMs at the same time, even more memory will be allocated for the second VM (which may not even be able to start if that memory is not available). On the other hand, you should specify as much as your guest OS (and your applications) will require to run properly.

I found this bit of information on their online users manual which you should also be sure to read over. It might have the information you need to get Swarm Agent to use the correct IP address. Be sure your network is set up correctly as well for VirtualBox.

Online Users Manual
https://www.virtualbox.org/wiki/VirtualBox

Cheers,

Andrew Hurley

The issue here is that I noticed the problem when the VirtualBox software was not running. It seems that the problem is caused simply by having the virtual network adapter installed. In theory the same behavior would be seen with any other software creating a virtual network adapter such as a VPN client, or even
just having more than one physical network adapter installed in the machine