Swarm Lightmass Coordinator not distributing jobs

I’ve tried to setup the lightmass agents and coordinators across two PCs but every time I try to build lighting only the local PC works on the job - the other PC sits completely idle.

I’ve attached screenshots to illustrate the problem, I have also attached screenshots of the settings I have used on both computers.

I was initiating the lighting build from the macbook using unreal engine 4.19.2 the build takes about 3-5 minutes to complete on the macbook alone.

The desktop is set as the coordinator.

I have tried the reverse as well - with the macbook as the coordinator and the desktop initiating the lighting build process but the results were the same - only the local computer was tasked with calculating the lighting. In this case the desktop takes about 15 minutes to finish the lighting build.

I have read through the documentation at:


but I could not find any clues that would help me solve this problem.

So I am not sure what the root cause is but I checked out commit 64882dd8e6a8711364a3857047d31167102ed846 of the unreal engine source and built the ‘Swarm Coordinator’ solution in unreal engine and it worked right away with the settings above, just in case anybody else runs into the same problem that I did!

It looks like I checked out that commit and built the swarm coordinator from that commit instead of using the one from the 4.19.2 commit. You can try downloading the engine source, going into git and checking out the commit referenced above and building the swarm coordinator to see if that solves your problem or not.

I have what sounds like the same problem you did. I don’t understand how you fixed it though. Can you please provide some more detailed information?

Thanks! I’ll give that a try!