Download

swarm hangs and never finishes building lighting

hey, I imported a scene with datasmith, set up some materials and lights in unreal and built the lighting, but it just don’t look good, lots of light bleeding, artifacts caused by low number of photons, all kinds of ugliness, so I manually uv mapped everything for lightmaps, reimported the whole scene, set maps to min 512 max 4096 (the max I can set in datasmith import, what makes most of my meshes have 1024 - 2048 maps, few things are actually 4096), added some lightmass portals and tried again. but swarm never finishes building. I even tried with a lower quality but apparently it’s resolution related, not quality, as it hangs in preview quality as well.

I have an 8 core ryzen cpu which doesn’t let me down rendering in vray, but swarm just doesn’t care about it. it renders for an hour or so, and then cpu usage goes down to idle, ram stays at 90%+ and swarm agent says it’s still going, but the building percentage never changes. I left it building the whole weekend last week but it stopped at 25%. swarm looked like it was still going so I left it doing it’s thing, but a couple days later it was still going, and still at 25% so I had to cancel.

I tried setting the resolution lower, tried a few settings for resolution on import like min 512 max 2048, or min 256 max 1024, but some work, some don’t, and the worst part is that it takes many hours to know if it will work or not, and if it doesn’t, I have to import the whole datasmith scene and set up everything again, which makes it pretty impossible to diagnose why swarm is hanging, and also impossible to diagnose if some lighting issues are resolution related.

It’s really frustrating, I assumed a final lightmap build would have everything at 4k max quality. I thought it would take a while, but given enough time it would finish eventually, but nope, it just hangs forever and I can’t know what’s the max resolution that won’t make it hang. and my scene isn’t that big, it’s a 300 object house, it’s not even final. can’t imagine how one would build lighting for a huge map.

why is this? what to do? is swarm just a piece of bad software? can I bake lightmaps separately? like build it for one mesh, finish, save, build for another? I even tried rendering with some other computers at work, but gave up after swarm agents couldn’t even ping the coordinator, so I’m really out of options here.

How much RAM do you have? Have you tried clearing the cache? https://docs.unrealengine.com/en-us/Engine/Rendering/LightingAndShadows/Lightmass/Unreal-Swarm-Overview

How many models are being baked? Have you tried simplifying the scene (baking just the room and hiding everything else just to see how long it takes?

I have 32gb of ram, and I always clear the cache, restart unreal, even the computer, it’s always the same deal.

currently I have 310 models on my scene, and if I hide all meshes but one it bakes all right, but I can’t unhide object by object and bake each time too see how many objects it can handle before it breaks, it takes about an hour of baking until I notice it won’t bake any further

A high resolution even on small objects is going to exponentially increase your build time. Are there objects that aren’t of high importance? Try setting those to 128 or 64 or even lower resolution.

What sort of scene is this? Bedroom? So almost like an arch-vis project? Do you have screenshots to share? What’s your lighting setup like? Generally it’s good practice to start with very, very low resolution and only add as needed. If you have a lot of little objects, even at 512 resolution that’s going to eat up a lot of your build time and RAM so the bake never completes. Hope this helps.