Download

Swarm Agents don't render :(

Hi,

I’ve some issues with the swarm agents. As you can see in the attached screenshot, the swarm manager recognizes them in the network but they simply don’t get the renderjob.
Pinging the manager does work on the client machines (they respond that the pinging was normal). When I start building the lighting in UE4, the agents or the manager don’t evenen show an error message. The console does not change.

Agents and manager are executed as administrator and not blocked by the firewall.

I’m grateful for any help :slight_smile:

07122faa0ffdbce9c25613e10e29120ee2ead831.jpeg

Best regards,
Daniel

Hi Daniel,

Have a look at this thread. It might be of any help

https://forums.unrealengine.com/showthread.php?95175-Swarm-on-renderfarm

Hi MSL,

thanks for your reply! I checked the link and the related tuts this led to some progress! I’m not sure what the mistake exactly was but I re entered all the necessary information into the fields and it this did the trick. But I’ve still some problems. 2 of my 4 machines won’t render correctly. The first machine stops after a very short time (“closing connection XXX using handle XXX”) and the second one does not even start rendering as you can see in the screenshot. The coordinator states that this pc would be “busy” but there’s no programm active except the swarm agent :frowning:

swarm_update.jpg

Swarm seems a little bit random to me because sometimes it works better and sometimes it does not work at all for me :smiley:

Any suggestions?

Best regards,
Daniel

I had similar issues and had to setup rules in the firewall settings.

For the spawn coordinator allow connections port 8009 for incoming requests.
For the spawn agents allow the program “spawn agent” for incoming requests.

For more information watch this video:
https://www.youtube.com/watch?v=dabo5OGtd20

I have the same window. My swarm agents won’t start building either.

I followed the tutorial video but it did not do any difference.

Seems all agents get ping responses from the coordinator, but not from each other (at least not in the log).

EDIT: Ok, the allowed remote group had to be changed as well, so now 1 out of 4 remote agents are actually working… the rest are responding to ping and available, even assigned, but refuse to work.

double check your antivirus / firewall. 9 times out of 10 that was the issue at my office.
Creating specific rules for the EXE files at their locations usually resolves the issues. - Do both Port and Program.

also, the windows public/private thing matters, make sure you configure it as open on both, or that all computers share the same type of network type.

Well, I updated my post above now, and the interesting thing is that the only remote agent doing any work now is one I haven’t touched the firewall on. Antivirus is the same for all machines, deployed by IT.

Doublecheck swarm settings for core and operational rules. Maybe something is preventing the jobs from being accepted at the config level. Only thing I can think of.

Back from the holidays, and now magically (without any change on the network or any of the involved machines, unless IT-Santa did something) I get one step further:

The swarm status window is, as you can see, always empty for some reason, but the log spits out a lot of stuff, so it looks as if it is working?

Spoke to soon, as I tried to get another node up and got the same “problem” as before:

I now see that the only different thing about the new node is that it has the correct username behind it (RNODE), whereas both Render-Z820 and Robert-T5810 actually displays the wrong user (it should also be RNODE)…

Well, this is a bloody mess imo.

First, overnight on a production render, I got the following on one of my agents (did not happen in preview quality):

Capture1.JPG
Capture2.JPG
Capture3.JPG
Capture4.JPG

Then, when I tried again, several agents complete their jobs within an hour, and then, after 8 hours, the 32-core machine still is working alone still at 10%. Why is that?

Oh, and my main PC just almost immediately goes to 99% completion in the Editor popup, regardless of actual progress.