Swam Agent - 4.18 - foliage error (solution)

Hi

There is a bug in new Swarm Agent with bigger number of Foliage. I have also found a solution to it. My friend have tested it and it is working fine on his machine but I found some topics that few people had the same error message in Swarm Agent.

Problem:

  1. Create basic scene (File->New->Default)

  2. Skale the floor to have room to paint the foliage - lets say 15x15x1

  3. Put basic cube into the Foliage (it can be anything but to keep it simple, put the Cube from StarterContent->Shapes-> Shape_Cube

  4. To make it faster change the Density/1Kuu to 5000

  5. Paint 150K cubes

  6. You can disable Cast Shadows on that foliage to see that this has nothing to do with it

  7. Hit Build Lighting Only on the default World Settings and on preview. After few seconds you will get an error

Solution:

  1. I had 4.14 installed on my computer so I have opened a blank scene.

  2. Hit the Build Lighting Only.

  3. Stop building or wait it to finish if you have blank scene, after the Swarm pop-us (it can be as icon on the bottom right)

  4. Now switch back to your scene from 4.18 but don`t close the swarm agent that opens with the 4.14

  5. Now hit Build Lighting Only, it should go fine with dense foliage.

Any idea what is going on?

Best,
Lucas

Same Error, I cannot use swarm from 4.18 for foliage cubes more than 160k.
I tested using swarm from 4.17 and your solution work :slight_smile:

Cheers,
Dominik

Hi Illusionray,

Thank you for your report. We will begin investigation into this issue as soon as possible. If we are unable to reproduce the problem, or need more information, we will follow up with some additional questions for you. Otherwise, we will post an ‘Answer’ once the issue has been logged in our bug database or we have a solution for it.

Hi Jon

Sure, let me know if you need more info.
As for the solution, I mentioned it above. Just open previous Swarm Agent first, then hit bake lighting in 4.18. It will render in the opened Swam Agent without opening the new one. Then it works everything just fine. :slight_smile:

Best,
Lucas

Thank you for submitting this bug report. I have reproduced this issue and logged a report for it here. You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Worth noting (since I don’t see it in the logged report) is that 4.14 is not absolutely necessary for a fix. I have the same issue in 4.18.3, and fixed it by running a Swarm Agent opened in a blank project in 4.17.2… Yet I see in the bug report that some users are reporting GETTING the problem with 4.17.2?

Point being, whatever’s going on here, it’s not something that was changed between 4.14 and 4.15’s versions of Swarm. 4.17’s version can work around it in at least some cases (such as mine)

Hey folks!

Great that the bug has been noticed.
@RhythmScript - I just had the same project on 4.14 and 4.18 and thats the reason I mentioned about 4.14 :slight_smile: I think that other version can work as you mention but just to be safe I wrote about 4.14 just to be safe that Epic staff can reproduce the bug. So, I may work on higher projects but personaly I didn`t test it.

One additional thing is that I have even checked the version of SwarmAgent and they are exactly the same. Maybe someone forgot to update the numerations on SwarmAgent ? ;D

This workaround does not work for me on 4.18.3, but putting all the foliage in it’s own sub level and unloading it allowed me to bake the lighting for the landscape.

I’m not yet sure if baking both the landscape level and the foliage level at the same time works or if the results of baking only the foliage lighting separately are visually ok, but I’ll keep you guys updated as my testing progresses.

Greetings
Andi

Ok so neither the foliage level alone nor the landscape and the foliage level combined will bake :-/