Surface Types are not being saved in Project Settings

I am trying to create a new Surface Type for my physical materials, and it works fine.
But, when I close editor, and open it again, new Surface type disappear, goes back to “None”.

And I can not even set as default, because that button is grayed out and it has this message:

“these settings are always saved in default configuration file, which is currently writable.”

I even deleted Save folder, and edited “DefaultEngine.ini” file, but as soon as I open editor, “None” comes back again.

UE 4.3.0


It looks like this is a bug. I have entered a report in our system for our developers to take a look at. Thanks for report!

I also confirmed this behaviour in 4.3.1
I though it was my Perforce locking up some files, but upon investigation, editor didn’t even write this settings anywhere in .ini file.

Just minor suggestion for EPIC, it’ll be nice to have a SAVE button for Project settings files and display which file is being written as configuration is changed in Project settings.

Thanks in advance.

This is still a bug in 4.4

How can we add our own surface types that will save? Thanks.

TheJamsh, I found a way around this. Add you surface types, then click Export and export a file. Then, click on import button,and import that file that you exported. For me, this save configuration, and next time I open editor, I don’t need to do that again. My settings are saved.

It looks like this bug is still being worked on, and earliest it would make it to engine would be 4.5 (TTP# 342555). In meantime, I have verified that Alex3d’s workaround works in 4.4. Thanks!

Just ran into this issue in 4.16.1 workaround from Alex3d worked but i just went to File → export selected, closed window and then import button and closed that window again. then i could see my surface types.

Good tip, your tip in particular saved me heaps of time, cheers!

Still a bug in 4.21! :\ I just closed project settings, closed physics material. Then reopened project settings (checked to see if changes were still there and they were) and then reopened physics material. They finally showed up.