Download

Support Compute Skin Cache & Force Recompute Tangents Issue/Uv Seams

I was using the support skin cache option and force recompute tangents, because i have some extreme morphs on my skeletal mesh and from what i understand fbx can’t save custom normals information for morph targets(if this information is true or not the fact is that i have some extreme morphs and they get bad shading when applied but with the support skin and force recompute tangents it’s fixed and was working just fine)

this function was working fine on 4.23 but now i migrated to 4.25 since it’s the latest stable version and it’s not working anymore, i even tested on 4.26 and the same issue occurs i have seams where my UVs are cut.

My character on 4.23/4.25 both on blank project using the support skin cache and force recompute tangent
Using the default material with only the color map

I Tried Using the “DeriveTangentBasis” Node and unticking Tangent Space Normal Solution but it doesn’t work, i also tried all sort of material settings with all maps, and all configurations possible for my normal map.

But what troubles me is that even without all those hacks this option worked fine on previous version of the unreal engine, i can only imagine it’s a bug???

One thing i also noticed that may be related is that the character in 4.23 has less vertices, it’s exactly the same character the same Fbx file, i created those 2 projects on .23 and .25 at the same time and used the default import options and have no idea why that happens

It’s not. They moved the option to somewhere else.
look in the materials tab for the skeletal mesh. Make sure the tangent recompute option is ticked.
I have this working fine in .25, so trust me. You need to just figure out the right settings.

Also, works fine in .26 with just upgrading the project from .25 even if .26 is a total mess.

Also worth mentioning. Make sure your mesh normals are the same on that seam.
and re-import the original model in case the engine decided to screw with it when upgrading from .23 - you never know.

Ok If i understand correctly, on .25 it’s working but it’s not out of the box like it used to be on previous versions and i need extra steps to make it work?

because like i said on prior to .25 i just needed to import my mesh and activate the function on project settings and it will work like i showed in the pictures, but on .25 there are extra steps, is that what you mean?

Cause i tried to change the settings both on the skeletal mesh persona and in the material and no luck, i considered it could be my mesh but since it works on prior to .25 and the normals are all fine i don’t think it’s the mesh.

i tried to change and mix match all those settings but no luck so far, at this point i’m feeling like a monkey just pressing random buttons to see if it will work XD

Open persona for the mesh. Look at the material slots. You should have a tangent space normal or similar checkbox there. That needs to be on for it to work in .25.

And yea, it doesn’t just work out of the box, not even if you expressily disable the normal and output tangent in the material. No idea why.

Also, as I said. if you just upgraded your project via the engine the mesh data could have been altered. I would just re-import the original to be safe.

You can visualize world normal to see if the edge has bad normals. Realistically it should just show you the mapped normal without any alterations if you are using an explicit tangent output like you mentioned trying.

if compute skin cash doesn’t work for whatever reason, just having the correct (same) normals between 2 edges effectively lessens the seam or completely removes it.

And no.
By default when you cut a mesh the edge seams do not usually have the same normal value (in blender anyway).
To get around it I usually make a copy of the mesh, cut one loop ring above the Seam on one, and one loop ring below the seam on another. I then shrink the 2 final loops so that they are contained inside the other geometry.
You need manifold geometry for proper mesh lighting anyway, otherwise things like transmission act up.

Another way, at least in the latest blender, is to copy the normals from the edge loop of one and paste them onto the edge loops of the other. You can easily do non manifold geometry that way. Useful some times on clothing.

If the normals aren’t the same, even with compute skin cache and custom values it is possible to see seams where there are none. Sort of like adding a sharp edge on geometry.

Also, before you say “can’t find it”. it’s well hidden: