Download

[SUPPORT] CAMERA 360 System

Hi!
This bug has already been fixed in all versions of camera 360.
All you have to do is update the 360 camera in your project.

  1. Open Epic Games Launcher
  2. Find Camera 360
  3. Update Camera 360
  4. Add your project and Replace.

It hasn’t been fixed.
I already updated camera360 and replaced it.
That was the latest version’s rendering image.
The image to be attached below is also the latest Camera360 and Unreal4.25.1 version’s rendering image.

Please screen settings Camera 360.
1.Try select Camera 360
2. Find Quality(Experimental) and True value check.
3. Quality -Try change value - 4096.

Hi, alexam87!

Thank you for your purchase.

You need paste in scene actors Camera Rec 360 and Camera Point 360 (from Content/Camera_360/Blueprints)
1.Select Camera Rec 360
2.Find option Quality(experimental) -> check value true and quality size 4096 px.
3.Find HighResShot option and change output size 8000x4000px and output path example C:/Picture (The higher the output image, the more pixels it captures example big picture Tutorial 12. Camera360 and Movie Render Pipeline (High Quality Media Export) - YouTube )
4.Press Play in game.
5.In Game press input key M ( screenshot)

Example working system https://youtu.be/XAT3CwxCP08?t=53 (but not use Rec value).

](filedata/fetch?id=1779457&d=1592886012)

Hi,

Is there way to get private support? My content is under NDA.

Thank you!

Hi, Yes, of cource. Please send me email [EMAIL=“Lenina62-ivan@mail.ru”]Lenina62-ivan@mail.ru

Hi, it turns out this project is not under NDA so I will just post my issues here:

Before purchasing your assets, we were using the built-in SceneCaptureCube to capture our 360 image, the problem with that was the quality was not good so you see a lot of ugly jagged lines in the image.

With your plugin, the anti aliasing works but the lightning does not seem to be correct. The image is darker. Can you tell me what to do to with it please.

Image when using built-in cube RT:

Image when using your plugin:

Hi!
I need to check. I’ll write later.
I think you need to adjust the Exposure a bit.
Find PostProcess in your scene and find Exposure and change bridgess.

  • for best quality
  1. Select Camera Rec 360
  2. Activate option Quality(Experimental)
  3. You used Realtime or Static picture?
    Change Texture Size to 4096 or better (5000-6000)
  4. Output size example 10000x5000 or 10000x10000 and change aspect ratio in any image editor. If aspect ratio 1:1 -> better for pixels.

I need checked color from camera 360. I write to later.

Hi,

Since we’re building a web application, we are not looking to get the best possible quality (we’re trying to balance between looking good enough and file size).
It was realtime when the 360 image was extracted (Everything was moving when the image was taken if that is what you are asking).
Our project is practically an open world project so we don’t have any postprocess actor in the scene as we don’t care about small details. Also Exposure is disabled for the project.

Hi, TCivilFX!
i understand you.
But you need to put PostProcess on the stage, otherwise you will have stitches if you do not specify the necessary settings. This is mandatory.
You can also change the brightness of the resulting image and contrast if necessary.
The fact is that the resulting image does not come directly from the cubic map, but from the camera, so there are slight differences in brightness.

](filedata/fetch?id=1779931&d=1592977768)

Important/Additional Notes:
Some Post processing does not work, artifacts appear in the form of seams.

Solutions:

  • Vignette = 0 (In Post Process);
  • Bloom = 0 (In Post Process);
  • ScreenSpace Reflection = 0 (In Postprocess);
  • Atmospheric Fog - volumetric off;
  • Exponecial Heigh Fog - volumetric off;
  • Directional Light - Light Shafts Off;
  • Exposure (Sometimes due to the uneven distribution of exposure occurs in the seam. Try to adjust the check Exposure method Manual and change Exposure value).
  • Ambient Occlusion (Sometimes).
  • DOF needs to be turned off;

Let me know if you need help if something doesn’t work out, I can connect to you directly.
[EMAIL=“Lenina62-ivan@mail.ru”]Lenina62-ivan@mail.ru

Hi!
I was asked why the camera doesn’t keep the 0.0.0 position

Hi!
Thank you very much for your feedback.
Sorry, the video is a little outdated. In new versions of Unreal Engine 4.24 and 4.25 need added + add Transform coordinate and set the values to 0.0.0.

](filedata/fetch?id=1780148&d=1593005147)

  1. Add Camera Point 360 to Sequence;
  2. Add Key for Transform 0.0.0

This should be done every time you change the camera. This problem in Engine 4.24 and 4.25. If you need, i create new tutorial very easy for this work.

Thank you for the fast reply!

following that tutorial i also cant get the export to work properly, i can seem to get it to capture in 360. im using 4.25. Thank you for the quick response!

Hi!
Write to me personally [EMAIL=“Lenina62-ivan@mail.ru”]Lenina62-ivan@mail.ru , I can connect with you directly tonight and help you.
I added tutorial https://youtu.be/BO6LiAyHyaU . The video will be uploaded within 20 minutes. tell me, did the solution help?

Hi, All!
Information for those who use stereo panoramic mode for create stereo images. A small error was detected with the number of frames per second.
Temporary solution:
Change Max FPS for Editor , example 30. And the frame rate for the stereo panorama will change to the desired one. Recomended 60 fps and change in video editor to 30 fps.
and to prevent frames from being skipped, the window must be active after rendering starts. You can’t go to other Windows or use the computer. Otherwise, frames will be skipped.

https://af12.mail.ru/cgi-bin/readmsg?id=15935084540383658847;0;1;11

**The fix has already. **

  1. Please Restart Epic Games Launcher
  2. Update Camera 360
  3. Add and replace Camera 360 in your project…

Hi, we have a stitching issue.

We’ve captured using the CAMERA 360 System with :

  • Post-process Volume and Chameleon post-process
  • No vignette
  • No bloom
  • PNG format

After capturing we’ve encoded the images using Adobe Media Encoder to H264 then we used Spatial Media Metadata Injector to play the video in 360 mode using common video players.
But we have this issue with almost all tested video players : GoPro VR Player 2.3, VLC 3.0.11 and Vimeo (Only “Movies & TV” from Windows have a different result)

360Addon-360Capture-IssueVisible.JPG

This is captured with the Unreal’s Panoramic Capture Tool and the same encoding process :

UnrealNatif-360Capture-NoIssueVisible.JPG
(But it takes 1min to capture one frame … so not suitable for production)

Good afternoon, corentin-dpt!
I am currently working on fixing this problem.
This is not related to the post-process.

As a temporary solution:
1.you can blur the lower part of the background in any video editor program;
2. Place a sphere or object with a blur material at the bottom, or darken the area.

Ok Great!
Unfortunately, blurring the problematic part of the image is not a valid solution for our project.
When can we expect a new version with this bug fixed?

Hi!
I’ll give you an answer tomorrow. I hope I can resolve this issue quickly.

**NEWS 07/02/2020. New update. **

  1. Please Restart Epic Games Launcher
  2. Update Camera 360
  3. Add and replace Camera 360 in your project…

Changes were made to the name of the modes. There will now be two modes available for rendering 360 images.

Modes_.jpg](filedata/fetch?id=1783494&d=1593704491)

  1. Mono 360 (Use 6 cameras) - uses 6 rendering render targets in the rig of 6 cameras. In this mode, if necessary, you can disable unnecessary cameras.
    Old name Mono (Left Eye)
  2. Mono 360 (Use 1 camera) - used 1 render target and 1 camera. Now there are no distortions at the bottom and top.

The format of the equilateral projection is slightly different for the two cameras.
Choose the one that suits you best.

Example image:
Use 1 camara.

](filedata/fetch?id=1783495&d=1593704603)
Used 6 cameras.
](filedata/fetch?id=1783496&d=1593704603)
Modes.jpg](filedata/fetch?id=1783497&d=1593705438)

If you have any errors, please let me know. The update has been sent to the store and will be available soon.

Hello,

I’m running into a tricky artifact when using Camera 360 plugin. I have tried all the methods that I deemed interesting in the forum but with no luck:

  • Disabling the post-process
  • Disabling the fog and reflections
  • Capturing in all 360 model planes
  • Activating “use separate process and close the editor when capturing”
  • Using manual mode capture You can find attached a picture showcasing the problem.

You can find below a picture of the artifact.

Does anyone know how to resolve the problem please?

Thanks a lot for your help !