Download

[SUPPORT] ArchViz Explorer

Can you try the following and let us know the outcome?

  • Get a reference of BP_Explorer_GI > Get Explorer_Main_Pawn > Set TargetArmLength_New

Thank you for asking. You can already upgrade it manually with no issues. We will upload a compatible version within this week.

It works! Thank you very much :sunny:

Please help. When I migrate project to 4.27 it doesn´t work again. I tried everything what I can. Does it work as usual in your 4.27 project? Thank you.

Do you only have issues with the spring arm?
Can you send me a PM?

Oh I solved issue. I created Game mode and set BP_Explorer_PC player controller and now it works. So I guess I cannot BP_Explorer_PC get reference. Thank you :slight_smile:

У меня к сожалению lerp теряется в timeline. Можно как-то это исправить? Спасибо))

I set it as is, but it doesn’t change.

When I checked the information of POI_Info_Struct as Multi-line, it seems that packaging is not working.
The error is attached as a photo.


Hey Stefan really great project and thanks for creating it.
I’m trying to remove the final two errors. The first is when the gallery button is pressed. This error appears in the output editor. The “Is Focusable” setting has been enabled on the widgets. Maybe not supported on mobile?
LogPlayerController: Error: InputMode:UIOnly - Attempting to focus Non-Focusable widget SObjectWidget [Widget.cpp(799)]!

The second appears on startup. An object is being spawned to the world.
LogSpawn: Warning: SpawnActor failed because no class was specified
Maybe I have removed something earlier.
Any help is very much appreciated, thank you.

It is common that doing changes inside a struct can lead to packaging issues. Please try the following:

  1. Create a new struct with a different name: Content Browser > Right-click > Blueprints > Structure.
  2. Recreate the same variables (and additional ones) in the new struct and delete the old struct.
  3. Choose the new struct in the Popup window and click Replace References.
  4. Package the Project.

Hey devzen,

Unfortunately, we are not familiar with those errors. Can you send me a PM so I can take a quick look at the issue via remote desktop?

Hey Stefan thanks very much for getting back to me. Turns out after migrating or zipping the project the HUD class in project settings was set to none. Seems to have solved that and the other errors I was getting. Everything fine at the moment I just need to reduce the package size so it opens on Iphone 6. Thanks for the offer I appreciate it.

Hi Stefan,
I want to use this app through pixel streaming. To stream it mainly on mobile devices. Do you have any experience with this? Do you think it will work? Thank you!

Hey Roman_Jambor,

I recommend that you check out Furioos and Eagle 3D

Loving your ArchVis Explorer as i’m learning UE :slightly_smiling_face:

I’m trying to replace the geometry of some of the POIs and have other POIs with the glowing boxes as it’s currently setup.

But it always seems to replace the geometry on all the POIs, wondered if you have any tips on how i can do this please?

thanks in advance

Hey Neil,

Thank you for the question.
After choosing POI, you will need to select the Static Mesh Component named POI_Geometry from the Details Panel and replace it with your custom mesh.

1 Like

Hi
Excellent solution for ArchViz. Adding to what Neil said, is it possible to make a video on how to customize the POI(s) to various floors and units in the mesh which will replace the one in the demo?

Also, unable to access the documentation on the web-site : https://www.karldetroit.com/archviz-explorer-documentation/

Thanks
GPuthige

Hey GPuthige,

You will need to create the POI meshes in your preferred 3D modeling software and import them to UE.

Our website is currently down. We are working on it and hope to get it online by tomorrow. I’m sorry for the inconvenience.

Thanks Stefan for the immediate response. Sorry, I framed the question wrong. I did my mesh in 3DS max and have imported into UE.

However, where I am facing an issue is when I move an existing POI to the new location (inside my mesh), the Camera does not move reciprocally. I have been adjusting the X and Y values under the Focus Settings but the values need to be adjusted considerably.

Was not sure if I am doing the right thing. Hence the request for a video if possible.

Secondly, I tried working with Cesium but had issues there. I did check on your earlier response on this and tried as per documentation, but the camera seems to be zooming out incrementally with every iteration.
Regards
GPuthige