Sun sky appears overexposed - change directional light intensity from 100,000 to 0.05 seems to fix things


I’m using a SunSky in a scene in UE 5. It was a project in 4.26, but I have imported it across.
I removed the other light elements from the 4.26 project and all that is left is the SunSky.
The scene though looks very over exposed. I have “Extend default luminance range in Auto Exposure settings” switched on as per the documentation.

The lighting looks much more normal when the Directional light intensity is taken from 100,000 down to .05 (if I take it to 0 there is no light at all in the scene).

I was wondering what might be the reason for this.


How are you setting the exposure in your scene?

Thx for replying. I have auto-exposure off - but when I do check it on - nothing changes.
Otherwise I don’t think i’ve altered the exposure settings. The world settings seem pretty standard and the camera settings are standard - I haven’t changed anything there.

In Unreal you need to set your exposure, you can “disable” auto-exposure but what you are really doing is telling the engine that you are going to set your exposure manually, if you don’t do that, your scene will be poorly exposed.

The SunSky actor uses realistic sunlight values, as I recall it typically requires an EV100 value around 12.5 or so.

Setting your exposure can be done via the “exposure” category of the Post Process volume (if you don’t have one, then you need to add it to your scene). It can also be set per-camera, and in the editor viewport. The editor viewport only applies to the editor, and camera settings will (if I recall correctly) override post process settings.

1 Like

“Extend default luminance range in Auto Exposure settings” actually creates a brightening or darkening depending on your settings (whether for camera or post process or other). It’s like expanding color gamut while keeping the same values, so changes have more sensitive or intense results. Is the scene using “Apply pre-exposure before wrapping to scene color”?