Download

Sun dosent cast shadows?

In my level you start in a close room with no light, and you go trugh a door to the outside world. Outside day/night cycle is very fast, and the shadows are therefore moveble, and set to cast shadows.

My problem is that the room where you start in the sunlight goes trugh the objects? i want it to be 100% dark in there. I dont get why it gets trugh the walls, i have tried building light, and nothing happens

Imgur

When i build light, it goes to like 14% and stops, it says in console that the map is too large, and it wont change anything in terms of performance.

Add a lightmass importance volume and also increase the lightmap resolution of your mesh.

Do you probably have a skylight in your level?

I’m pretty new. What is a lightmass importance volume and where can i find this?

Go to the volume tab and there you just have to drag and drop it into your level + scale it up
**
What is a lightmass importance volume:**

"Many maps have meshes out to the edge of the grid in the editor, but the actual playable area that needs high quality lighting is much smaller. Lightmass emits photons based on the size of the level, so those background meshes will greatly increase the number of photons that need to be emitted, and lighting build times will increase. The LightmassImportanceVolume controls the area that Lightmass emits photons in, allowing you to concentrate it only on the area that needs detailed indirect lighting. Areas outside the importance volume get only one bounce of indirect lighting at a lower quality. "

Nothing changes by doing this :frowning:

Could you probably just upload the map + the meshes that are causing the problem? That would be the easiest way how we can find out how to solve the problem :slight_smile:

I cant really upload the map as i have cunstom models in it, so i guess it wont work? I can give you more pics with my settings:

Is the room a static mesh or a bsp brush? -> because then I will try to reproduce your problem

  • which lights are you using?

You could also just delete all your custom stuff out from the map, because I would just need the room :wink:

I tried both bsp brush and mesh, i’m only using the lightsource.

i belive the problem lies in that the sun rotates and therefore have to make new shadows all the time, im almost 100% sure that it has something to do with this, because before i did the rotation thing it worked

Hmm, I wasn’t able to reproduce your problem :frowning: -> have you already tried to delete the door and block it with a static mesh, because probably there some light leaks in (I have read that in a old thread from the UDK times ^^)

Also make sure that dynamic shadows are turned on in the light and mesh properties

Thanks man, i blocked the door with an invisible wall and it worked :smiley:

:cool: my time that I have spent in the UDK community is pretty useful