Download

Suddenly, huge polycount?

Hello people! I have a very weird issue, and I really hope someone can clarify this for me. Also, I’m not sure whether this is the right place to post it, I’m sorry if it isn’t!
I have a scene - all dynamic lighting. I made it like this, since I wanted to create this faster, and because shadows looks more ‘crisp’. Now, I suddenly ran into a performance problem today. Weird thing is, the Unreal scene says it has 1mil tris in the camera viewport (with the “Stats Engine” command), and the scene is only 220k tris in Maya. This makes no sense in my mind, but here are the pictures :

Unreal :
5c96feba09fe0eb15454a49de66b5f09e32d6fbe.png

Maya :
9484a8b720c7f4d41fd90995a9065e5f39ed2297.png

Unreal Statistics :
a3516893b1e99fcd1b0435b967762e07f028f1d9.png

I know the statistics show 343k tris, but that is because I am streaming two levels at the same time - the scene from Maya, plus one more scene, that is about 100k tris. Why is this happening? Any ideas?

every light that casts shadows has to render the affecting geometry again (to make the shadowmap) which results in increased polycounts

aside from using dynamic lights, what other details can you give in terms of your light setup?

Alright, time for update. After further investigation, and this time this is in the editor viewport :

Both the first level and the persistent level on :

Only the first level on :

Only the persistent level on :

Let’s see now. For some reason, the combination of those two is what kills my game.
Only in the apartment - 103k tris. Perfectly fine, and it is normal. Then, only in the persistent level - 63k. I have no idea where does it take those 63k from, but that’s alright (since the other scene isn’t in the viewport). Then for some reason, the combination of 103k and 63k is 971k tris?! How does that even, WHAT? I am really, really hoping this is a mistake on my end and not the engine’s fault! In the persistent level, I have only my post-process volume, a skylight, the directional light (sun) and an atmospheric fog. Nothing that has topology.

I use LPV, directional light with indirect lighting, AO turned on and 3 other light sources with shadows turned on in the scene. The rest of the lighting is with no shadows. So if I reduce the amount of lights that have shadows on, the problem will disappear?

After further investigation, it is my directional light that’s causing the problems. How do I make it less demanding?

what shadow settings does it have?

My Directional Light settings :
8319b510438df13792f87b5cfb65bc42a7ea9266.png
a3d673ddc2c84aa5c9def3c140e9cf38f9ba04d7.png
5882ef45b9b431998c4d1e6b4dc104b6a4060f23.png

Thanks!