Suddenly cannot find Header files in Plugins

Hi, I have a suite of plugins that has been working for months. This morning i open the .sln, and suddenly all the plugin headers cannot be found. They are in the same place on disk, and i have not changed the code at all.

And, here is where it gets weird…

An old project that worked fine a day ago… same issue.
A brand new project, with the plugin, unchanged from a day ago… same issue.
A completely different plugin, also working fine a day ago… same thing.
A different computer, any of the 5 plugins that worked great a day ago… same thing!

4.13, same thing. 4.14, same thing.

Why would this suddenly happen? Across multiple plugins, multiple projects, multiple engine versions. It make no sense at all.

To be clear:

I open the visual studio solution (cleanly rebuilt).
I open a .cpp file from any of the plugin’s ‘Private’ folders.
Intelsense complains about all plugin headers, and a right click/open document gives the ‘cannot find’ error.

It will compile fine, but any plugin nodes in blueprints are no longer found. However, it does let me make new ones, from the plugin code. WTF.

Am I missing something stupid here? Any ideas gratefully accepted!

Hi ,

I just wanted to confirm that you are seeing the exact same behavior in the last three Engine versions, and this is not limited to just 4.15. Would it be possible to get a sample project with a plugin that is exhibiting this behavior to look into?

Hi ,

We have not heard back from you for a while. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment to this post and re-open it if you need any additional assistance.

Thanks , a clean install, using binary, not source, has fixed this issue. Go ahead and close it.