Subtractive Brush Not Working

I am trying to make a window using a BSP box brush set to subtractive. I am placing it on another BSP box brush and it will not subtract.

The only way for it to work would be if I add a completely new BSP box first, and then add a completely new subtractive one. But even then, it only subtracts the new BSP box and not all the ones I have already placed prior.

Anyone know what’s wrong or what I am doing wrong?

1 Like

Hello ,

From your screenshot it looks like you have a subtractive brush inside of another subtractive brush. If this is what you are doing then it won’t work. Think about if you took a glass a water and you emptied it. Then you tried to empty it again. There is no water left so there is nothing left inside the glass.

If this is not the case, you will have to build in order for the subtraction to actually take place. Also you need to have an additive brush in order for the subtraction to be taken away.

In the image above, it is a subtractive brush inside of an additive brush.

By build do you mean build my project? Hmm, I didn’t try that, but it makes sense.

Anyway, I ended up creating new brushes (with the same properties) and deleted the old ones. Then when I added subtractive brushes they worked.

I will try building next time if this happens again! Thanks!

I recently had this problem as well and I can say something else to look out for is if you’re working with merging different levels into one, make sure that the addition and subtractive brushes in question are made in the same level.

1 Like

I think the issue appears because of the order that these additive/subtractive shapes are created.

Additive then Subtractive works,

then create a new Additive, if you move the Subtractive shape to work with this new shape it fails.

My solution:

If you have a Subtrative shape that doesn’t work just cut then paste it in the same place. This way is treated as a new entity.


This worked for me in 2021. Clean and simple answer. Thanks.

1 Like

when you don’t even remember that you posted this and what was all about

Thank you! I made a copy of my level, and then subtractive failed. Then you mentioned that subtractive is dependant on the level it’s created in. I don’t undetand why subtractive doesn’t work when it issent to another level.

I had the same problem, then @pdcsky said that if the subtractive is not created in the current level, but perhapse copied, then it won’t work. So I just CTR+D to duplicate the subtractive object and voila! It work worked. Su, if your subtractive is not working, then duplicate it and delete the initial subtractive.

You are a genius.

my friend, i have big doubts about that

Well gotta start somewhere, right? :+1:

This was the first and onliest response here that actually helped. Spanks!