Download

Substance to UE4 Issue - Black metal in UE4 Viewport

Hey,

I’ve got a bit of an issue importing my Substance materials into UE4. The materials import as they should, with the exception of colors being a little off, which has no doubt something to do with the lighting. However my metallic material shows up as black in the viewport, it looks fine in the material editor but not in the viewport or when I hit play. I’m not sure if this is an issue with Substance Designer, UE4 or both, but I figure that since the material looks right in the material editor it’s not completely wrong when published from Designer.

Does anyone have a clue what the issue might be? I’ve checked to make sure that all greyscale images don’t have sRGB checked and vice versa.

In Designer

ri8sxZJ.png

In UE4

Wz3vmaS.jpg

have you added a reflection capture actor to your scene? I had an issue like this a while ago and that was the cause, might help might not.

Yep, metals depend on good reflections for their appearance. The material editor has a cubemap built in.

Ah, yes, seems like that was the problem. Adding a Sphere Reflection actor made the metal behave more like actual metal, thanks a bunch.

glad it worked for you:)

Ohoy again!

I’ve got another small issue I’ve noticed, this time related to the normal map. In UE4 the normal map, when appled to the wood material of the door, har a lot of artifacts in it, taking away a lot of the detail form the base color map. The normal map is set at 2k, which I think shouldn’t make it appear so jagged. Could this be because of the lighting or was the normal map not exported correctly perhaps?

Without normal

BbkuWfU.jpg

With normal

1cbc6702195da7a4764c13be9466463c9e5c1f6e.jpeg

Can you show us the normal map texture inside Unreal? I want to rule out poor execution; sometimes normal maps that are generated quickly from photos are really noisy, or people crank up their contrast too much. Also, is it compressed with the default normal map settings, like turning off sRGB, compressing with TC_NormalMap, etc?

Maybe it would look better with a roughness map instead of a normal map? That’s what I would do. I always find normal maps to give exaggerated results but it’s probably cause I don’t use well made maps… Roughness maps gives me great results tho!