Substance .png textures are brighter in the Editor than the preview.


i exported .pngs from Substance Designer and imported them into my project.
Dark textures seem to become much brighter in UE4.
When I uncheck sRGB in the 2D edit window, they look dark as they’re supposed to, BUT only there in the 2d view.
As soon as I use them in a material and apply this material to a static mesh, they’re bright again, as if I did not uncheck sRGB.

Hope anyone can help me

1 Like

We have had this issue as well and haven’t figured out what the issue is.

I realize this thread is a bit old, but I’m having the same issue too. Did any of you figure out a fix for this?

Same problem here.

Try exporting the files as 8-bit instead of 16-bit. I have experienced this too, and this solved it for me.

Hi Kenomica, I assume you’re referring to Substance Painter (where the export does have options for 8-bit/16-bit etc). Substance Designer on the other hand doesn’t seem to provide these options on export. Can someone confirm?

I’m not sure if the new Substance Designer 5 offers these options though as I haven’t upgraded (yet!)

I’ve also not upgraded to SD5 either, but there are options to export via 8 or 16 bit. Make sure your format is set to 8-bit (rather than relative to parent)

Sorry I can’t provide more clear instructions, it’s been a while since I’ve used it.

Hmm I see what you mean, although changing from ‘relative to parent’ to ‘absolute’ (8bit) overrides all channels and there’s doesn’t seem to be a way to override roughness alone making the workflow a bit cumbersome. I think I read on the forums that 24bit TGA is recommended for normal maps.

I can understand that, I personally only use 8-bit for low memory usage - but it depends on your needs.

It would be worth a try just to see if it fixes the issue though, since it’s non-destructive you can go back to the original format again after testing.

I started using .tga instead of .png, which solved the problem for me.

We had the same issue using PNG 24’s that we made in Photoshop and found a work around. When saving the PNG just make sure the “Convert to sRBG” is checked ON and the “Transparency” is checked OFF. (See image below)

We make our Alphas and Diffuse maps as seperate textures by the way so this solution may not work for everyones pipeline.