Structs keep disconnecting in 4.12

A while ago i showed this error as in the video:

Its a very critical bug, but the user tsuki had found a solution to that.
He got his contributer badge through that.

Now im asking myself: Why is this bugfix in the 4.12 master but still not in the previews :c
Im fearing that you guys will delay that bugfix :c wich would be realy bad!

Pls give information on that


Change 2910968 on 2016/03/15 by .Oconnor

PR #2152: Fix for UE-27652 (Contributed by SNikon)


These are the important refs to the gitstore-

Someone did resolve that wrongly.
This is not cleared or resolved.

Stephen Ellis send me here so i can get information and now someone just closed this thing without any word.

Is it not in the previews because of testing?
Because of time?
Will it be in the final release?

I converted your Answer to a comment, so no one can accept it for now.

Whoever did that: Would be nice to leave a small comment when accepting stuff :smiley:

Hello Filly_The_Owl,

I’m taking a look into this now. From the information I’m seeing, it should have been in 4.12 when it first branched. I’m going to manually look for the change at some certain points and see if it was taken out for any reason. I’ll try to get back to your shortly.

See that youtube video up there?
Take the marketplace asset and do the exact same thing. Thats the most detailed report i can give and the one that helps me the most.


I will retry that entire stuff in the video too now. Just for the test. But im 1000% sure its still broken.

I gave it another test like in the video… with 4.12.5 and had the same exact errors. And tsuki just told me that the 2 files very surely are the main files that could prevent this bug.

Thx… im a bit mad now after all that work tsuki put into the bugfix and you guys just decided NOPE we dont need that.

From looking at the code, it seems like SNikon’s fix is implemented in the latest Preview and has been in since before 4.12 branched off of Master, meaning that it was in 4.12 the entire time.

As for what was checked in, as SNikon mentioned in his Pull Request, only the edits to K2Node_VariableGet were intended so the other two edited files were ignored. When .Oconnor committed these changes, he created a function called RestoreSplitPins instead of just using one implementation of this code and called that where SNikon’s code would have been along with a few other places.

If you’re still experiencing the issue that this was meant to fix (UE-27652 for my own reference) then please let me know and I’ll see if I can reproduce it soon. If so, we’ll need to get that bug report reopened as it is currently closed due to this fix.

4.12 is a preview I don’t get why someone would complain about that

This is still a threat :c bump

The remaining files just need to be put in the master that should fix it!

Maybe you should start reading first then before posting? And honestly your comment is not constructive. Tell your opinions anywhere else and stay on topic pls.

Please keep the discussion civil. I was unavailable for the holiday weekend so I’ll be taking a look at this now and I’ll get back to you shortly.

I’ve attempted reproducing this in the latest 4.12 Preview but haven’t had any luck doing so. I tried the same reproduction steps in 4.11.2 however and did reproduce the issue. Have you been able to reproduce this issue with anything other than the Survival Game Template?

Also, since you mentioned that all that needs to be done is to add the remaining files from that pull request, please be aware that they have nothing to do with this case and are of a different nature, as they deal with UMG directly. Adding those files would most likely not have any effect on this issue.

This error is still here.
And all the errors in the video stated are in the umg.

How did you tried reproducing? Did you took the sgt template? I tested this pls do as i.

I’ll give it a shot on the Survival Game Template. I wanted to see if I could reproduce it outside of the project first however as we need to find the cause for the issue, not a one off case where it occurs.

Thx! Now we talkin business! You will see how just broken it is on sgt. :slight_smile:

Any updates?

Hello Filly_The_Owl & Smurfies,

I hoped to get this done before the weekend but wanted a little more time to look into it. From looking at the difference in reproduction steps and the symptoms, this actually seems like a separate bug. One of the main reasons is because of the fact that, in the original bug, the thing that was being changed was the value of the variable, not the variable type. On top of that, it would only disconnect pins related to that specific variable in the struct, not the entire struct pin.

From what I’ve tested, tsuki’s PR did fix that original issue. This particular one did slip through the cracks however. Seeing as this is still occurring, I’ve placed a new bug in for the issue under UE-31679 seeing as we do have a reproduction case now. The only thing that irks me a bit is that I wasn’t able to get it to happen outside of the Survival Game Template, even after trying to take direct blueprints from it. It means that this may be deeper than it seems.

Thank you for being persistent about this issue. I’ll be sure to keep you updated whenever any changes happen to the bug report. Have a nice day!

Thank you very much.

I recently had this on 4.12.2 release version from the hub. what fixed this issue for me was:

  • Delete/ReAdd the get nodes of the Struct Arrays
  • Rename the struct to something different
  • Do “Fix Up Redirections in Folder” on the Content folder.

maybe this will be useful for somebody

I can confirm that this works! Thank you!