Strong/thick fog?

I’m wondering what would be the best way to do a thick heavy fog where the view distance would be a few meters.

I tried playing with the height and atmospheric fogs however even when maxed they did not limit visibility enough.

Something like this. Would it be better achieved with some particle system spawning around the player?

You could fake it with a mesh and material which is attached to your character or camera. It would be a kind of fake volumetric effect, like in the weather fx pack on the marketplace.
For the material you would need a cloud texture/mask created in Photoshop or in Substance Designer, than connect it to a panner node to make the clouds move. Than setup everything with the emissive and opacity slots to make it work.
Of course there is a bit more to setup but i think there is good tutorial on youtube for a volumetric fog/light effect.

Are you sure the heightfog isn’t dense enough? Look pretty limiting to me hehe…


The Exp Height Fog will serve your needs, but the Z location of the fog actor needs to be near the Z location of the camera. If it’s significantly below the camera, then the effect will be greatly lessened.

Thanks for the replies guys.

For the most part, the height fog is enough.

However as can be seen from the screenshot, the sky unfortunately doesn’t get blocked nearly enough.

Settings screenshot.

I tried moving the z location up/down like kirk.clawson and found the point where its the thickest, which is where the screenshot is from. If I moved it either up/down from that point it started thinning out. However the sky doesn’t get blocked more than this.

Am I missing something simple (like usually)?

Try dropping your falloff to something very small like 0.001

Hm, I must be doing something terribly wrong here…



I’m seeing surprisingly little difference.

Looks like you have two height fogs and an atmo fog in your scene. I’ve seen weird things when you have multiple fog types in one scene.

Also, you might try dialing back the inscattering settings, that might help.

Wow, I’m an idiot. Thank you. I can’t believe it was so simple. Appreciate the help greatly. I had no idea the different fog types would blend so badly.

The solution was to turn off the atmospheric fog.

The second height fog seemed to have no effect on anything, either on/off.

If you want something more volumetric, here’s a post process material you can use.

// RayMarchFog CMOT Float 4

float3 lightvec = normalize(float3(0.687334,0.506979,-0.520138));
float stepsize=100;
float numsteps=50;
float mul=0.0;
float4 sum={0,0,0,0};
for(int i=0;i<numsteps;i++)
if( sum.a > 1) break;
float rt=stepsizemul(1+(dither/2-0.25));
float3 pos=rtrd+ro;
if(rt>scenedepth) break;
float3 noisepos1=pos.zxy+float3(300
float dens=clamp(MaterialExpressionNoise(noisepos1/500, 0.10000000, 0.00000000, 0.00000000, 1.00000000, 2.00000000, -0.10000000, 1.00000000, 2.00000000, 0.00000000)/3,0,1);
float4 col=float4(dens,dens,dens,dens)fogcol;
float dif=clamp(MaterialExpressionNoise((noisepos1+lightvec
100)/500, 0.10000000, 0.00000000, 0.00000000, 1.00000000, 2.00000000, -0.100000000, 1.00000000, 2.00000000, 0.00000000)/3,0,1);;
if (mul>49) sum.a=1;
return clamp(sum,0,1);


Nice! Thank you!

So sorry to necro a thread, but how do I add the “RayMarchFog” Node - I am assuming it’s custom C+ that is provided in the post, but how do I add that in UE4?


**@Abstracted **look up the “custom node”

Hi everyone, I tried to do the post process material but get this error. It seems that there is no function that gets 10 parameters in MaterialExpressionNoise …

Anyone know how to fix this error ?

But why would you need that when there is Volumetric fog that is already implemented in the engine? Add a exponential heigh fog to the scene and check the Volumetric fog checkbox. :slight_smile:

I was trying the volumetric fog thing. I’m trying to create a nebula in space. So when I’m at a certain distance from the " volumetric fog " it disappears . Can’t see it . Maybe there’s a solution to the disappearing volumetric fog but I didn’t find it .

Volumetric fog has a limited distance of 6000 by default.
You can change it with a console variable.
But you are better off faking it with meshes

Do you have any example ?

Try reducing the inscattering color values to black or dark grey, and lower the alpha value of inscattering. Inscattering is the light that is bouncing off of would-be fog droplets or particles and is used for sky rays and see through steam and stuff. Look up the tutorial on volumetric fog in the learning portal too. I’m certain it has some applicable information for developing a dense volume of fog. One more, is the directional light set to be the atmosphere sun / fog? If so, uncheck it or disable that and it might change to being more dense and less translucent.

My problem with volumetric fog is that at certain distance is dissapearing :slight_smile: . Because of the limited distance that can go up to 10000 I think . I need the distance about 50000 or more . That’s why I was searching for something else .