Download

Strange skylight effect. HELP

I only have a skylight, my directional light is turned off.
I have tried increasing the resolution of the meshes but it doesn’t fix it
I have looked online for how to fix it but I haven’t found it.
This is my problem, I don’t even know what to call it, it looks like the light is going through something that makes it pixelated.

Production Build doesn’t help also.

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“custom”,“data-tempid”:“temp_197129_1594201483430_580”,“height”:“407”,“width”:“701”}[/ATTACH]

Is the scene using HDRi backdrop? What are the skylight settings (screenshot of upper details panel and settings under Lighting)?

Yes, the scene has a HDRI backdrop, here are the settings:


So, I think there could be something in the HDRi that is not set right. Source Cubemap Angle looks really high, though not sure if that’d cause the pixelation noise. What are the other settings of the HDRi?

In World Lightmass settings, try changing Diffuse Boost back to the default of 1. We’re looking for ways to get the engine to be able to solve that noise. Even if it means modifying things until the scene is a bit altered by the modifications, then it could be corrected after that. If it doesn’t need correcting after modifications to remove the noise, then that’d be great. Another thing to try is changing the skylight’s “Sky Distance Threshold” so the scene is outside of the value. So, it’s currently at 150,000, and the skylight is located at about 158 units above the ground plane. Set the Threshold value to 10 or 20, I think, unless the scene is higher up from the ground plane and would still be within the threshold distance. It probably won’t solve the noise completely, but it might help for modifying other settings. I’ve changed it before to be outside the distance threshold, and it changed the intensity of the lighting and helped reflective surfaces become more noticeable and accurate, I think.

In addition, what are the post process volume settings for Auto Exposure, Ambient Occlusion, Global Illumination, and any other settings that are enabled in it?

Ok so I have tried many thing and always building the light between them but they all didn’t fix the pixelation noise.
I did the Diffuse back to 1, I set the Sky Distance Threshold to 15. The house is quite high above the sphere where the HDRi is tho.

I also tried to build without the skylight and without the HDRi, having only a Directional light. Got the same result.

Bellow I took some screenshots of the PPV settings

Here are the HDRi settings


Ok, thanks for replying quickly. I thought it might be longer to go through those different things.

A few things concerning the settings you posted:

A) Ambient occlusion, in the PPV (not RTAO), has a radius of 15. That’s extremely small, and with such a bright HDRi, I think it is not accurate. It may also be contributing to the noise. Try a minimum of 100, maximum of 250. Increase the Intensity to 0.5 at least.

B) Reduce the Brightness of the HDRi a bit, to no lower than 0.5, but probably around .7-.9. (It’s a REALLY BRIGHT HDRi, lol. It translates to a heavy influence on the lighting of the scene because it has an internal skylight (a skylight always comes with any HDRi and so is connected to its settings in how it affects lighting). I think that’s a part of WHY there’s noise in the first place. Somehow, not all of the lighting info is getting fully processed for the scene, specifically wider, flat surfaces where it is the most noticeable. Though it’s also affecting other surfaces too. Which brings this to another point:

C) Materials on the surfaces - what are the resolutions of the different materials on those surfaces? If they’re 128 or lower, they’re probably too low of a resolution to get a fine-tuned, non-noisy result. But again, it is most likely in conjunction with the other settings for the HDRi and directional light. Which also brings me to another point (HA HA HA, not really funny yet it is if there’s humor to be found in such a mysterious problem)…

D) Even in deleting the HDRi and its internal skylight (if you added a skylight, that means there was an extra, so 2 skylights, and that would probably screw up the lighting / produce noise), the data of the previous lighting build could remain. In effect, it’s not a proper test of what’s causing the noise. One way I’ve read to remove the old data of the last lighting build action is to go to World Lightmass settings, and temporarily put a check in “Force No Precomputed Lighting”. That removes the old data of lighting and switches the scene to calculate only dynamic lighting (all lights would need to be set to movable, and objects too probably). But instead of continuing in ‘force no precomputed’ mode, simply uncheck it after checking it, and it’s back to calculating static / stationary lighting. One other approach to removing the old data is clearing the cache of the Swarm Agent (the application that processes much of the lighting build). So, while UE is opened, there’s a little icon in the taskbar for the Swarm Agent, go to it and look for Clear Cache. Use it, and then restart Unreal Engine. This restarting is after also checking and unchecking “Force No Precomputed Lighting”.

E) Lastly, if the sphere ground plane is far below the house / buildings to be lit, and the skylight is at 158 Z, then 15 would be enough to get the scene outside of the distance threshold. What is the Z location of the scene objects, roughly?

F) The inside of the house looks rather dim, so in decreasing Brightness of the HDRi, offset it by increasing Indirect Lighting Intensity of the skylight and increasing Intensity of the directional light. The stronger the directional light is in Intensity, the stronger the indirect lighting is going to be because every indirect bounce of light is a fraction of the previous cast of light (1st bounce has an intensity that is a percentage of the first, direct cast). But this is based on the materials’ diffuse value. So, a higher base color (diffuse) value in materials results in higher intensity bounces of light. Hence, increasing Intensity of the directional light AND the skylight is going to allow Indirect Intensity and bounces to be stronger, and may even remove some of the noise, while also lighting up those interior areas.

G) Set RTGI (in the PPV) to Brute Force method. Set Max Bounces to 2-4, and Samples to 4-8.

H) Turn SSR (Screen Space Reflections) off for now. It can interfere with RT reflections, which could interfere with lighting on semi-reflective surfaces such as the walls, ceilings, floors, etc.

Before I followed what you said I reduced the light bounces and it cleared up a bit but as soon as bring more bounces it goes back to where it was.
But as soon as I corrected points A and B it made a massive difference already, the noise is practically gone. The AO on the PPV I did intensity of 0.5 and radius of 150.

C) The materials on the surfaces the actual maps are from 512 to 2048, the light map resolutions go from 128 to 512 and ocasionaly to 1024. On the lightmap density I try to keep everything on the green and then I work from there up but the green is my base. When I’m modeling I have the light maps density in consideration.

D) I didn’t know about that “Force No Precomputed Lighting” I thought Unreal starts baking light from scratch on every build. So as A and B worked out pretty good I haven’t tested this button yet but it makes sense if having 2 skylights, the actual one and the data from the previous one that would screw up things pretty bad.

E) The house has a Z location of 170.0, I would say that the house is in the center of the sphere.

F) I knew a bit about it but the way you explained now everything makes more sense, it actually lighted up in my mind lol
I will actually have to read it a few more times to make sure I understand it and don’t forget it, Thank you!

G and H done also

There is still a bit to clear up and I will get to it in the morning and send you some screenshots here.

That’s great. I read somewhere in the forums and I think in the docs too…that the more lighting (such as Intensity, Brightness, number of bounces, etc) there is, the more samples are needed to compensate for it and for the denoiser to handle. It could also be the same for greater amount of shadowing, but it is dependent on settings and how those work in conjunction. So, it’s really not easy to develop scene lighting fast and without tweaking much.

Is the HDRi a dome type? There’s dome, cube, and a presentation cube that’s similar to a white, photographic cube utilized for specific presentation purposes. I know the HDRi is an image projected on a sphere. If it’s possible to do, locate the skylight higher up above the house / scene, so at maybe 1000 or 10,000 instead of 170. Just to see how it affects things, if it is going to do so. If it’s not desirable results, then change back to 170 or 200. But it could be the house / structures are overlapping the Sky Distance Threshold value, which could be altering the static lighting results, thus biasing for one light (skylight) over another (directional light), or vice versa (biasing in favor of directional over skylight). Remember that a directional light casts its lighting in one direction according to the rotation of it. So, if the directional light is rotated so its lighting is casting on the scene at an acute angle to the ground (as if it is morning), then it’s going to impact the build results differently than a higher angle cast (as if it’s noon or 2-3 pm). It affects the intensity, brightness, where/how light bounces occur, and also the appearance of shadows (hard edges or softer, area shadows, and shadow darkness).

For lightmap resolution, I suggest trying 256 and up for interior surfaces / objects (except small objects, such as lamps, decor, etc), and 128-512 for exterior. Interior is getting lit more by indirect lighting, so increasing resolution for some surfaces should result in a finer detail of lighting information, which means more discernible differences in tighter spaces and open spaces in terms of lighting. Then again, the skylight of the HDRi casts light everywhere, and is why I suggested decreasing its Brightness to account for the increase in directional light Intensity.

Alright after a few hour going through everything you told me and experimenting a bit more I manage to get somewhere! Not 100% yet but I found something interesting.

Oh btw the HDRi I got it from “HDRI HAVEN” I am not sure if its a dome or sphere but I placed it on a sphere.

A) So changing the Z of the skylight and the Sky Distance Threshold didn’t do anything, I have the house at Z 170 and I left the Sky Distance Threshold at 1500 its quite above the house so it will be fine.

B) “Force No Precomputed Lighting” that button in my case didn’t help as I was playing with it, clearing cache on the Swarm agent and restarting the software but didn’t change much.

Now the last thing you told me to do is what made a massive difference which is to change the lightmap resolution. So the higher the resolution the smaller the noise, but it never disappears completely.

On the left as you see you have a wall with 128 of resolution and on the right you have the exact same wall and same angle with 256 of resolution.

On the opposite side wall will be easier to see what happens when I bump it to 1024 resolution, its practically gone but not actually gone. Once I zoom in on the red circled area its still there.


I don’t know if I’m being way too perfectionist but the way I see the problem is still there, we just found a way to make it smaller…

As I had the resolutions between 256 and 512, occasionally 1024 I had build times of about 10 to 15 seconds having everything around 1024 and 2048 gives me about 5 times longer the build times (Production Build). In Lightmap Density Viewmode now everything is red, is that normal thing to work with?

Note: Its still a bit dark inside as I only have the skylight and the HDRi, the Directional Light is off. Plus I haven’t adjusted the light intensities.

The resolution increase causes higher build times, and it doesn’t sufficiently solve the noise. Turn the directional light back on, and try a build before adjusting intensities. You’re likely already doing this before receiving this reply. I thought the resolution change by itself wouldn’t solve noise completely, and it really shouldn’t because resolution is a measure of the number of pixels in the visual. It’ll only solve it if it’s super high, and already close to being solved / noise almost gone, in lots of cases I would think. That’s why the scene needs more lighting data, and there’s probably a setting or two at least in the project settings and/or World Lightmass, PPV, and probably still those meshes. Is DirectX 12 enabled in the Project settings, in Platforms > Windows? What are the Rendering > Optimization settings in the project settings? This is why it’s easier to share project files, but my 4.25 version wasn’t working last I checked. I also don’t have the best computer for ray tracing (can’t use higher number of samples per pixel).

Tinker with the intensities of directional, skylight, and HDRi. Don’t make directional lower intensity change than skylight. Directional is going to produce more lighting in the interior areas through indirect bounces, and could solve that noise without introducing new problems better. I say that because the skylight is connected to the HDRi, but I could be off about it.

I am here giving a link to Dropbox with 3 zipped files, you can choose any of them to download.

testhouseFULLmaterials - All the materials in the project
testhouse - Only walls, floor and stairs
testhouseNOmaterials - No materials at all

If on any of them if you use the Lighting Only Viewmode they all look the same with the same noise.

So just to make sure the problem wasn’t the sphere I created I added from the Engine an HDRi Backdrop and changed the cubemap to the one I had.
I applied the same settings and I got the same results, the same noise.

I kept tweeking the lightmass and intensities to try and minimize the noise and its almost gone. My Directional Light was always Off, I was working only with the skylight and HDRi.
Once I build using the Directional Light not much changed regarding the noise.

Just for the reference I am using UE 4.25.3, GPU Lightmass, the RayTracing is Off and DirectX12

Alright, I downloaded the FULLMATERIALS version, and I’m going to check it in a bit. It’ll probably be another hour or two before I reply back. That’s quite weird with the directional light. Turning it off initially didn’t solve any noise, but now turning it on brings noise back after solving most of the noise with only the skylight and HDRI. Where is the ground plane in reference to the HDRI (at the equator of the sphere, or above or below it)?

Ok, I think I found the problem

GPU Lightmass is the issue. Once I switched back to rendering with the CPU all the pixelation disappeared.

As you downloaded already give it a try rendering with the CPU. You shouldn’t have any pixelation…
The ground plane should at the equator of the sphere more or less.

The problem might be that I’m using a “GPULightmass 4.25.1 release” in a 4.25.3 software.
But I guess this is a problem for another thread.

The reason I did it is that in this project:
GPU takes in “Production” about 20s to render
CPU takes me in “High” about 2m30s to render

Let me know once you did a render if you had the pixelation.

Is the download file for 4.24 or 4.25?

The file that is on Dropbox is for 4.25.3
The GPUlightmass that I was using is the 4.25.1

If anyone is seeing this post with the same problem on the GPU Lightmass the solution is very simple. This is what I was told by another member:

This will fix all the noise in your scene.
Thank you L1z4rD89 and presto423 for the help