Strange shadows when using dynamic light

Hello everyone. I enabled dynamic light by setting directional light and a mesh to movable. Then I added cascades and configured all things by Lighting Troubleshooting Guide. But result is awful:

What is wrong? Thanks.

How did you ‘add cascades’, surely that’s the default.

Does your mesh look in the mesh editor?

Does it look ok if you use a standard mesh, like the cube?

I added cascades in “Cascaded shadow maps” section in directional light settings. Mesh (in Maya) is ok, no artifacts. But standart cube looks normal:confused:
Yes you are right, problem is with cascades. In my first screenshot, number of cascades was 4. Here number of cascades is 1:

P.S. sorry for my bad english

Yes, but cascade = 1 is crap :slight_smile:

Have you tried turning off distance fields ( project settings… )

Yes, I tried to turn it off and on, no results:(

Hmmmm… tried it a with a large cylinder. Distance fields on, dynamic skylight and directional light. I can’t get these artifacts.

I guess it could be to do with your import workflow. Are you just dumping an FBX from Maya?

Have you tried Datasmith?

I agree, maybe the problem is connected with exporting. I just used “export to fbx”. I will try “send to unreal” option in maya

This is due to Shadow Biasing

Here’s a big thread on this issue Dynamic shadows artifacts - Feedback for Unreal Engine team - Unreal Engine Forums

One of the easiest “fixes” is to use more geometry.