Strange shadows on wall-floor.

Hi. I am having problems with the lighting on this scene. I post a map with the zone where I have strange shadows. I use static meshes for the models and static lights. Each room has a UVW mapping on channel 2 for the shadows, but it’s strange because on the second picture (number 1) the shadow affects to two diferrents static meshes.

What am I doing wrong?

Try increasing the mesh’s lightmap resolution.

I am using a 2048 lightmap. Do I increase to 4096? And why does the door have the same problem?

2048 is fine. Maybe there’s light leakage. Try changing your material to 2 sided and ur mesh to 2 sided shadows. I assume ur light quality is under preview, try changing it to production and see if it helps.

I will try, but I think that it’s not possible on my computer.

Well, u can always put it to render while you’re sleeping.

I tought that I had a 2048 resolution, but it was 1024. I wil build it with 2048 and production quality. The 2 sided option I think it won’t work, but I will try it later.

I have the same problem.

Hello pnunez,

So from what you describe and your screenshots that you have posted what I believe is happening is a light leaking issue. This is typically caused by multiple walls created from different objects that have been placed so that they shouldn’t allow lighting or shadows to leak through. However, this can cause problems as your lightmaps are bleeding across from one object to the other.

The easiest fix for this is to create your walls and building with one mesh. So creating a two sides box that is hollowed.

I am linking you to our lighting troubleshooting guide that should help you in case you get stuck or have any questions. This guide covers a variety of issues, not all, but should help you with this one.

Thanks,

Logan