Strange shadows baked with GPU Lightmass

I tried to bake a test scene with UE4.27.1 GPU Lightmass. The indirect lighting looks great, but the shadows produced by the directional light look strange. The shadows of all static objects in the picture below don’t look correct. I have modified the “Overriden Lightmap Res” of each actor to 256 or 512; and the UV1 of these furniture models also looks good; please help, in the end What is wrong, or am I doing something wrong?

By increasing the Lightmap res resolution of the floor to 4096, I got a result that looks pretty good. But it seems that GPU Lightmass uses a liquefaction effect when dealing with low-resolution situations, rather than blurring. Like the tree in the picture below, to make its shadow look correct, I need to let the shadow receiver set a very high Lightmap Res, which seems to be inconsistent with CPU Lightmass. How can I set up to get a fuzzy shadow when Lightmap Res is small, instead of liquefied?

By the way, thank you very much for your prompt reply!

The same scene baked with CPU lightmass while the floor’s Lightmap Res is 1024. I get a fuzzy shadow looks much more reasonable.

It the lightmap res of the floor that’s the problem. You either need to crank it right up to a ridiculous amount, or break the floor into sections :slight_smile:

So, what should I do to bake soft shadows with GPU Lightmass?

In the end I found the answer: because I used a stationary direction light, what I still need to do is to check “Use Area Shadows for Stationary Light” to get the soft shadow effect. The reason why it took me so long to find this method is because Epic mixed the configuration items of CPU lightmass and GPU lightmass. Some options are only valid for CPU baking, while others will affect GPU baking at the same time.

1 Like