Strange Shadow

Why the shadow is curved?

Beacuse the lightmap?

Hey xXTrollBrosXx,

I noticed that your mesh receiving the shadow is actually a BSP brush. Notice how the default material appears stretched? Try turning them into squares instead of the elongated rectangles. Once you do that, convert your brush to a static mesh and rebuild your Lightmass.

Hopefully these suggestions resolve your issue, but if you are still experiencing this scattered shadow effect let me know and we can try some other options.


fixed it. thanks

The shadow curved again. Please Help!!

After I changed the point light shown above to a static light, it becomes worse:

Later, I changed the point light to a stationary light, it becomes worst:

I’ve checked that the UVs belonging to these two object is correct.

Hello xXTrollBrosXx,

Would you mind showing me a couple screenshots of both of your Static Mesh settings for the object casting the shadow, and the floor mesh receiving the shadow?

Usually this occurs when the mesh receiving the shadow has an improper resolution. In your case this would be the greenish floor mesh.


This is the part 1 of thestatic mesh setting of the mesh that casting the shadow:

This is the part 2 (the UV showing is the lightmap):

This is the part 1 of the static mesh setting of the mesh that receiving the shadow:

This is the part 2 (the UV showing is the lightmap):

Finally, this is the material:

Hey again xXTrollBrosXx,

So I took a look over your images you posted and it seems you are generating Lightmap UVs for meshes that already have the correct UV layout and spacing.

Try changing your ‘Lightmap Coordinate Index’ back to 0 for each mesh, which will force your static meshes to use the ‘UV Channel 0’ unwrap for light computations.

Let me know if this resolves your issue, or if you need further help.


Fixed it again. Thank you for your great helping :slight_smile: