Download

Strange seams/darker mesh

Hey Guys,

I have a little problem regarding a mesh. I created 2 modular pieces, and the window part is a bit darker (they both use the same texture).

HighresScreenshot00005.png

HighresScreenshot00007.png

So my problems are these darker parts and the seams on the window.

To solve it I first switched to unlit mode.

HighresScreenshot00006.png

HighresScreenshot00008.png

As there are no more seams I think its safe to say, that its not a material problem.

What means it has to be an issue with the lightning.

Next I found a tutorial about shadow bleeding by WorldOfLevelDesign, which said I would have to break up my Lightmap to get rid of these seams.

So did this and this is the result (the new lightmap is on the window on the left (from the front)):

HighresScreenshot00010.png

HighresScreenshot00009.png

As you can see this didnt solve my problem at all, the textures also completely messed up.

Here are some screenshots of the lightmaps.

Original lightmap:

AutoScreenshot.png

Exploded lightmap (messed up):

Screenshot_1.png

I hope you can help me resolve this, if you need any more screenshots/details just ask for them, ill do my best to provide them.

Thanks for every reply

that’s a known issue with no water-proof fix. co-planar faces with baked lighting do produce those differences. you can try to minimize the effect with various solutions like better lightmaps, higher lightmap res, tweaked lightmass settings, etc. but your best bet would be to design your modular pieces in such a way that you either do not have connecting edges on flat surfaces or add some architectural feature there to hide the connecting edges.

ok, thanks for the reply, ill try to add some architectural things on top

There’s a couple of things,

First is your lightmap UV’s, they are split up too much, you have some very small islands there which need to be attached to other pieces otherwise it requires a high resolution lightmap to avoid issues.

The lighting differences though can be a result of the lighting system as described here: https://wiki.unrealengine.com/LightingTroubleshootingGuide#Shadow_Seams.2FShading_Differences_with_Indirect_Lighting

You say that you made the components ? If so what app.

I’ve seen this effect a few times using 3ds Max with components with messed up smoothing groups.

Another cause is using the scale tool with out resetting the xform. Using Max always always always reset the xform on the object before exporting. :wink: