Strange Oculus Light Problem

I have lights attached to VR oculus controllers in my scene acting as flashlights, but whenever I move them around I get a very strange distortion around the edge of the light, almost like heat distortion around a flame. Has anyone else experienced this issue?

It is difficult to tell just from a brief description. This could be linked to Motion Blur, Temporal AA, frame rate, late update or something else.

What is your setup? Which AA method are you using? Are you using the Forward Renderer? Did you profile your experience? What is your frame rate from the Oculus Debug Tool?

I’m currently using forward rendering with MSAA, and I don’t have any motion blur enabled. Ran the profiler and it said it had 1951 accumulated frames and 2958 missed, so I guess this is a frame rate issue? The weird thing is I ran this experience on the vive and had no issues.

What is the Oculus Debug Tool showing? Frame Rate? Dropped Frames?

I used the Oculus debug profiler which said 1951 accumulated frames and 2958 missed. Just ran the lost frame capture and in 2:28 I had 12598 total frames and 5195 lost frames with a frame rate of 90 fps.

Just had a strange development, when I run the exe through the debug with the lost frame capture recording, I don’t experience any issues and the experience runs completely fine?

Another new strange development, the exe runs completely fine when I run it as the administrator, is that normal?

Is it possible that when run as admin the application gets more priority, but it is not supposed to happen. At least you should see some differences in the performance HUD vs. when you run it not in admin mode. Can you just have a look at what the Performance HUD shows in one case vs. the other?

Ok I launched the exe in the debug normally and as an administrator and everything was around the same. The app frame rate was 36 hz, latency was 70-80 ms, and the compositor dropped 90 frames, but in the admin launched version I wasn’t having that strange issue.

Still strange. Can you try to adjust the priority of the OVRServer_x64.exe service and see if that makes a difference when running in normal mode? You should also play with the ASW setting in the Oculus Debug Tool.

I also suggest to cross-post this on the Oculus forum, it seems to be more Oculus specific than UE4 specific, but it is difficult to tell so far.

Ok just tried everything you suggested and I noticed by enabling “Force 45fps, ASW enabled” I was getting that weird distortion regardless of whether I started normal or as an admin, but it went away when I started as an admin with “Force 45fps, ASW disabled.”

Just started it normally with “Force 45fps, ASW disabled” and it finally runs without those distortions.