Download

Strange light inside room!

Hi guys,
I can’t properly set the illumination in Unreal. In the picture below I’m inside a completely closed room so it should be totally dark, instead is bright.
GI is set as dynamic SSGI and no baked lights, I see it depends on skylight and sunlight but of course I cant change a well done daylight illumination

Any help please?

anyone :slight_smile: ? Please

You still have to bake even though you aren’t using static lights.

Also a moveable skylight might help.

EDIT: Only one build though, just to reset the lightmaps.

@ClockworkOcean, for fully dynamic lighting (no static lights, Force No Pre-comp Lighting enabled), is it necessary to build lighting when changing the dynamic lighting after the initial build to reset? So if I change a number of settings for directional, skylight, and any other dynamic lights, do I need to build again?

Sometimes I’m not seeing changes when changing settings, whereas other changes are visible during / after changing settings.

No, you only have to build once after changing to reset the lightmaps, after that it’s all dynamic.

I don’t know if this is a known thing, but I’ve found that if you’ve been using any sort of buildable lighting, you will have to build just once after you switch to moveable.

Thank you guys, I did everythings you said.

Force No Pre-comp Lighting is enabled in my project
SSGI activated
Skylight and DirectionalLight are movable

I see that it basically depends on GI but I can’t create “darkness” in a closed room

You can create darkness in a closed room. Place a post process volume around the room, or within it so the bounds of the PPV are right at the edges. Then set the Exposure to either Histogram or Basic, and modify the Min/Max and Exposure Compensation to generate darkness in the room. You’ll need to change the Blend Radius, possibly Blend Weight, and perhaps the Speed settings too. Uncheck the Unbound property so it’s not covering the entire level, only the room or the area within the PPV.

Blend Radius controls how far the post process settings are blended with the areas surrounding the placed post process volume. So, if it’s set to 100, then there’s a blend of 100 Unreal Units (or 100 cm at default) between the lighting surrounding the post process volume, and the lighting inside the post process volume. Not sure if the blend overlaps the edges of the PPV bounds, but you’d probably be capable of discerning it by trying it and modifying to see it change in the editor viewport.

Blend Weight controls the intensity of the blend within the PPV, and can have an effect on the transition area between the volume bounds (light purple square) and the outside of it, depending on the Blend Radius value.

Speed, under Exposure, is for how quickly the lighting transitions from outside the PPV to inside it. So, if it’s a dark room having a sudden change from a bright room to the dark room, then set the Speed Up or Down values accordingly. It’s probably best to try those after successfully getting the room darkness level intended.

Thanks Presto, but it should be fully dynamic and based on sunlight, otherwise it’s impossible for me to create manyPostProcessVolume for each environment in the scene.
Even because I have a Post process volume set for the entire World. :frowning:

At the moment the GI in other space works amazingly! The problem is in a close room!

And also if I get closer to a dark corner I should see darkness , instead if a go into a large room with big windows I should see GI and Skylight work much more… this is what I want to achieve

Could be a limitation of the experimental SSGI. I haven’t used it enough yet that I replicated the same problem. What number of dark rooms are there in the scene? Is it a bunch of completely closed rooms?

It´s most likely your skylight. Remember, the skylight acts like a reguar cubemap, that is mixed with every mesh and material, that is in the world to fake GI. Go check the skylight and look for a checkbox, that says “Affects world” and uncheck it. If the room interior turns completely black, then you have found your culprit.

But of course, without it affecting the world, you lose a big part of outside lighting. Best would be, if we could tell some meshes or materials to be ignored by the Skylight, or maybe toggle the intensity of the skylight down to zero, once you get inside (would probably be the easiest way, if the intensity can be linked to some collisions or triggers, to control its intensity for certain areas).

Presto, yes it is a game and I have a lot of rooms :slight_smile:

Suthriel, what you said is correct but unchecking “Affect the World” changes completely the lighting system and skylight matters.

Guys I have partially solved the problem at 80%. Basically I’ve seen that **PLAYING THE GAME **the light system return to his original settings, instead in the editor I got issues.

So now I create a closed room that is partially dark! A bit better… but now I have to find the way to make darker …

That´s why i mentioned, toggeling it´s intenesity to zero just in certain areas, like interors, rooms, caves, and bringing it back to normal intensity (1) as soon, as you get back into outside area.

Check triggers, you can link them to the intensity of the skylight.

https://youtube.com/watch?v=h3AMMm3566Y

This feature is called “Auto Exposure”. It sounds like, as if you have turned off Auto Exposure for your Editor, while it´s still active during playmode. You can switch to different Exposure methods via Post Process, and in the Editor, check under the “Lit” Tab, if “Game Settings” is used. If it´s active, then your editor should use, whatever mode your game is using for exposure. If its inactive, then you have a fixed manual Exposure setting, that you can adjust with the slide right below it.

Game Settings.jpg

Thanks buddy… :slight_smile: I can work for the project, but the light in the ditor will be a bit different from the project at runtime… but it’s fine, the project matters!

Also, found something other you might want to check: The (Distance Field) Ambient Occlusion settings. From start, they are set in a way, that they make it hard to create black caves, but with raising their values, i could get really dark places:

Link to the manual: https://docs.unrealengine.com/en-US/Engine/Rendering/LightingAndShadows/DistanceFieldAmbientOcclusion/index.html

Video:

https://youtube.com/watch?v=gUGPvzkdkbQ

I think this is a serious real issue. I created a question for reference regarding this problem: [Lighting][Bug?] Dynamic Lighting/Shadow Issue Inside a Room - UE4 AnswerHub

Baking doesn’t help. Even with all lights set to movable.