Strange edge on simple circle texture

I’ve been baffled by this for over an hour now tried many different settings. I’m not doing anything complex, I just want to create a simple transparent circle texture but every time I bring it into unreal I get a strange edge or a horribly aliased edge.

I’ve tried sizes from 256x256 up to 1024x1024, preferably I’d rather a smaller size as it’s not exactly a very detailed texture but regardless of the size I get ugly edges, I’ve tried disabling mipmaps, messed with streaming settings, tried normal transparent layer in Photoshop, as well as using an actual masked alpha channel but the results are usually always the same.

The only difference I’m noticing is if I set my material between translucent and masked. Masked causes the funky unsmooth edge you see in the screenshot below, whilst translucent causes highly blurred edges, though helped somewhat by increasing the size, a 1024x1024 resolution version of the texture is still very blurry up close.

Not sure if i’m missing something very fundamental or not.

The “masked” blend mode basically uses the opacity mask you give it to determine which pixels should be 100% opaque or 100% translucent. You get better translucency with the Translucent blend mode, but it limits your material in other ways. Probably just use translucent and fool around with the texture settings until it looks good.

So I changed the material to just use translucent, which I had done earlier. The results I get from a 512x512 are disappointing. 512 isn’t exactly a high-quality resolution, however I would have thought it’d be adequate enough for a simple circle texture to give it adequate results.

Normally it would be, it depends on the amount of surface you’re stretching it across. Looks like a lot.

I’m using a squished default cube that is scaled by 2x its normal size, though overall its smaller than the majority of the starter content props and shapes

For the most part its better, the doesn’t seem much I can do besides increasing the actual texture size, 1024x1024 is pretty decent as long as you’re not zoomed too close to the line. Turning mipmaps off or setting it to only use bias 0 in the sample node inside the material helps a bit.

For some reason even when you’re right on top of the material in the editor it won’t display mipmap level 0, only 1.