Strange Bug with stereo

I’m currently developping an application for a Samsung Galaxy S7, the game should run on Gear VR. But I have a strange bug. Everything compile fine but when I launch the application the two screen generated by the stereo are not well placed on the screen. The right stereo screen is half outside the mobile “physical” screen.
I’m on 4.14.3, and I saw that Mobile Multi View is experimental. I think it might come from this, but I can’t disable it. (The check box in unchecked, but in the app log when I launch it, it’s writted that it’s enabled.)
You will find my log as attachement.

Hi Space Bar,

I think you might need to disable Vulkan. According to a post by an Oculus team member from 2 days ago they still do not support Vulkan. Very sad, I know, but hopefully they will support it soon.

I have disabled it, the demo is called VulkanPerfect because I tried to cook for Vulkan and Gear VR. But I disabled it for the tests. The cook was for OpenGL ES2.

This could also be related to Mobile HDR and your AA setting. Try disabling HDR just to test to see if that works. If so then some AAs don’t work with mobile HDR selected.

Vulkan does not work for Gear VR, is a fact. Mobile HDR works fine, but with horrible performance.

So for Vulkan I knew it. I just named the project like that. But for this cook it was OpenGL ES2. Gear VR, Mobile HDR enabled, and TemporalAA. Normally the demo run at 60fps (because there is nothing in the scene).
But here is a video to show you the bug.

Gear VR Strange Stereo Bug - YouTube.

So I tried with another project without Mobile HDR enabled (without multiview), and it give me a black screen ! (The project work on Cardboard !)
@motorsep, as I can see on the occulus forum, you’re really active. Do you succeed in cooking an app for Samsung S7 for Gear VR with UE4.14.3 ? If yes, can you share your config (like AA, Mobile HDR, Multi-view Target SDK, and other things like that !)

And I have a question, do Gear VR support arm64 ? I don’t think so, but I want to be sure !

Temporal AA either won’t work on Gear VR or will cause issues. Gear VR runs with hardware MSAA x2.

Mobile HDR causes x2 fps drop, even with empty scene.

Multiview is in alpha, so it causes fps drop too.

I have S6, and yes, I have no problem running UE 4.14.3 projects on Gear VR. GLES 2.0 and nothing fancy (no HDR, no multiview, no AA). I simply followed Epic’s docs for Gear VR since 4.9 and never had any issues.

No, UE4 doesn’t support arm64 builds (or maybe it does, but build fails; I don’t recall why, maybe FMOD didn’t have arm64 libs or maybe something else). I don’t know if Oculus Mobile SDK supports it (maybe it does, but maybe their FMOD plugins don’t have arm64 builds)

That’s strange with MSAA X2, because when I enter r.MobileMSAA 2 in console commande on the phone, the app crash !
And, is it mandatory to build for SDK 19 for Gear VR ? Or Higher work too ?

Okay, so finally it was the Mobile HDR, you were right !
For the AA, I didn’t know that Gear VR has a “Built-in AA” and that I was able to let “none” in the AA settings (in rendering). Still I enabled r.MobileMSAA = 1 and r.MobileOnChipMSAA = 1. It work perfectly, even if I loose a bit of quality on reflections, but the FPS are smoother.
Thank you guys for your answers, and Happy developing !

tyring to do this for Oculus Quest 2, HDR messes it up every time. I tried HDR on with Vulcan off, ARM 7, mutiview off which it requires greyed out when hdr is on anyway, I need HDR on for a specific reason any work around here. maybe another setting that needs on or off for HDR to work?