Download

Stop UE4/5 from trying load SteamVR when not working on VR project

Sorry if this the wrong place for this, nothing else seemed a good fit either.

Anyway, I’m pretty new to Unreal so please excuse my ignorance. How do I stop Unreal from loading SteamVR every time it launches? I’m pretty sure that the first several times I loaded Unreal it didn’t load my Steam VR. Until the day I tried to go in and see what the development windows and tools looked like for developing for VR and started a VR project. Now, every single time I load Unreal it also loads my Steam VR and complains when it can’t find the headset. Trying UE5 today and I can’t even get it to load, it just crashes partway through starting a porject and I think it’s crashing because it’s trying to load SteamVR . I don’t think they’re playing well together on my system. Why won’t Unreal wait until I’m actually loading a VR project before trying to load Steam VR? It’s going to be a long time before I’m ready to work on a VR project so that’s just resources being wasted.

So yeah, how can I stop that? Thanks.

Yep it’s annoying. Go into plugins from the top tool bar, under edit i believe. Then just search for vr and untick all the vr plugins

1 Like

There must be something else going on. I went in and disabled Oculus and Steam VR plugins, shut down bot Unreal and the Epic launcher, and ensured that Steam and Oculus weren’t running. And yet loading Unreal again still tries to find my headset. I don’t see any other VR related plugins running so I’m not sure where else to look.

Unreal will load default plugins, because they are (and always were) set to enabled by default.
Look for Engine\Plugins\Runtime\Steam\SteamVR\SteamVR.uplugin and set “EnabledByDefault” to false, it wont bother you any longer. You can enable the steamvr again in project plugins if needed for a project.

1 Like