Stop Niagara system popping in when camera sees it?

I have created a sequence where a camera pans up a candle to the light at the top - the flame is a niagara sequence. It pops in, meaning its glow is not visible before the camera sees it.

I don’t want this to happen - I’d like its particles visible before the emitter itself is in shot.

I followed advice from other threads about setting the bounds bigger and also about pushing the Niagara track to before the sequence starts, but no luck. Does anyone have any idea how to fix this?

Did you work out a fix for this? I have the same issue.

Hey there @tonygillham and @JollyTarkaVFX! Welcome back to the community! Particles rendering is actually based on their bounding box (at least in realtime), so I’m assuming this fix should apply for rendering as well. Head over to the emitter settings, change “Calculate bounds Mode” to fixed, then set a large size. This will make it always render, which is great for rendering as you don’t have to worry about performance as much as realtime games. Let me know how it goes!


This fixed for me. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.