Download

Still having trouble with light shining inside enclosed buildings. Any help??

Been trying to fix this for a month now.

SCREENSHOT: http://i.imgur.com/w5D3NSP.png

In the screenshot above you can see I have a small building that consists of the following:

9 floor meshes
4 walls - 2 meshes wide
9 ceiling meshes

I built the lighting and what seems like a completely closed in box reveals light coming in at the corners on 2 of the walls.

I set the whole building to two sided lighting and it gets worse, the 2 walls you see that are lit up at the top become completely lit up from top to bottom.

I tried setting the whole building to non-two sided lighting and I get what you see above.

This is using the default 3rd person template, all I did was import a bunch of meshes and built a small building.

Seriously, been bugging the **** out of me for a solid month now. What am I doing wrong?

Don’t forget, in unreal the backface of a polygon is culled (invisible) so it will let light pass tru it.

I will try that, appreciate it. Since I’m still pretty new inside of UE didn’t know what normals was used, like every house have blocking volumes around it? I’m sure if I saw a half completed game and seen how they actually threw millions of diff stuff in I wouldn’t think it was odd. Just trying to not CLUTTER my game with so much stuff, if that sounds right.

My previous post was a bit erroneous. I double checked in the engine.

For archviz it’s just usually better to make walls with thickness to avoid all potential light leaks. But you could also successfully just use ‘‘two sided’’ in your material settings. That’s the easiest way of doing things and works fine too.

Blocking volumes could be used in arch-viz if you don’t have thick walls and have some leaks (at the jonction of walls and ceiling for example!

What may be happenning in your scene is lightmap bleeding. If the lightmap of your mesh is low resolution and there is a part of the mesh receiving light, it may bleed into the section that is supposed to be dark. sorry for the bad explanation english isn’t my mother tongue.

How thick is thick enough? I usually set my walls to 0.25 as that seems like a decent size.

Also for clarification, I’m not doing arch-viz, I’m actually having the trouble in making a game, where I would make a house and have a day / night cycle and as the sun moved the inside of the house would light up different colors depending on the location of the sun. Then would have problems of just the top corners where the walls and ceilings met would be lit a bit.

I will try once again to make the walls, ceilings, floors two-sided lighting and then making the materials 2 sided, and if that don’t work I’ll go with blocking volumes.