Still having issues with Texture wrap

I have posted before about an issue with the material wrap around this one pillar. We got the material to wrap, but we still have this seam that shows up and it only happens when the light is rendered. I loaded a new level and brought the mesh in and wrapped it the shame way i did in the level i am working on and built light only, it was still there. Any ideas? here is a picture?

seam unreal.png

Update: here is a better image and the seam is only on the one side

Hi,

Are you using a normal map at all for your mesh?

Also can you post a screen shot of your UV for your textures and your UV for your lightmaps?

The edge shadow could be the result of the lightmap if you’ve not got enough spacing between edges or the UV island is too close to the 0,1 space edge.

Thank you!

Tim

It’s not a spacing issue because the spacing for the lightmap UV was adjusted with more than enough spacing since the last post. I will post both UV maps in a moment.

&stc=1

sorry for some reason in cam in huge and twice. But I hope this is what you where looking for.

Yeah looking at what you’ve got looks good.

Give this a try: Create a new material and plug a Constant Vector 3 color into base color and apply that to the mesh. Choose a light color, probably something like a white, light orange, etc.

Once you get this applied to your mesh build lighting.

If you’re no longer seeing any line at the seam the issue is with the texture you’re using and the colors not matching up.

Let me know how it goes! :slight_smile:

Tim

We created a new meterial using the vector 3, using a very light yellow, the seam still appears

In the “go advanced” mode you can delete those “extra” pictures -> just click onto the “manage attachment” button and then delete them from the “add to line” list.

Now to your problem :slight_smile:

-your lightmap looks correct, but do you probably get any light errors when you build the light?
-with: “only happens when the light is rendered” you mean after you have build the light?
-your mesh is one single mesh or have you combined it in the editor or import window (combine meshes)?
-check if your normals are pointing into the right direction

Or the easiest way is to upload the mesh somewhere so that we can take a look at it :slight_smile:

It’s only a single mesh and yes I do mean after the build. As far as “uploading the mesh somewhere”, I could attach it in here but it doesn’t seem to except the appropriate file format. Do you have a preferred way for me to send this to you?

You can use whatever you like :slight_smile: → e.g gdrive, dropbox,…

Is there a way we could zip the file and then post it in here (to make life easier)?

I think the only way how you could upload something is on answerhub (but then you will have to create another post). Otherwise you can also send it as an e-mail (metalgamestudios@gmail.com) or over skype (nasph96) -> but recommended is a way that other people can also take a look at it (faster answer ^^)

Okay so I put it in a zipped file on the answer hub, it wouldn’t let me send it anyother way for some reason. but I also put a link back to this forum and here is a link to the answerhub, sorry i fixed the link

:wink: I think you have posted the wrong link -> it just leads me to a “ask a question” site

Edit:

Ah, now I see it

https://answers.unrealengine.com/questions/96985/seam-issues-on-mesh.html

Hmm ok, either your import settings (have you changed anything?) or your texture (diffuse, normal map) is causing the problem -> somehow I dont see a seam (or probably I’m just blind :p) Have you already tried to increase the lightmap resolution (in the static mesh editor)

8b7d251b42be40c5f333fd96339f69d1681b2a2f.jpeg

Yes we have changed the res for the lightmap, maybe it’s our import settings when we brought it in to ue4, what were your settings when you imported? i.e. We have something like this set:

fafeb4b643eac4a5105bc4eff69337f6b5e33ed1.png

also would sending you the material help?

Edit: LOD Group is set to architecture

I will post you my import settings when I’m back home :slight_smile: Yep, I think it would help when you send me the material, because as you have seen above, I dont get the strange seam

the material is up and now that i look at that image you sent me, i do see a bit of a seam there in the lighting (second lip from the bottom in the center)

Hi,

I just checked the zip file and there isn’t a material with it. Can you reupload?

Thanks!

Tim

Sorry Tim for the late reply, was having other issues with the blue print aspect of unreal, but there is a new zipped file attached to a comment on the answer hub right here.