Stereoscopic3D ( No Occulus)

Hello together,

yes it is quite frequently asked around the forum, but i really want to know how to enable the Splitscreen (Stereoscopic) in Debug mode.
As you can read here
there is a direct solution for having a side by side view. So if i know how to find this debug setting, i would use it not for debugging but for the 3D Beamer i got.
I guess this would also help to solve any questions similar to this.

So please, where is it, where can we activate the dummy device ?
Thanks in Advance and greetings

I believe the command line option is ‘-emulatestereo’. Let me know if that doesn’t work for you.

Ah yes i remember that command line.But that only gave me command not recognized.
Is there something i have to enable or to do before i can activate the command line ?

Thanks in Advance and greetings

Hello again, i found a solution, and it looks like this :

It is a Red Cyan test, because i have no software/hardware at home to test out if the shutter glasses will work. The projector will use it for the shutter technology.
The problem for now is that i don´t know how to build a blueprint pawn that has the camera for the Player one and the Player two so that the player one controlls the movement, and player two is only simulated to get the stereoscopic. If the other stereo mode can also simulate two “eyes” i won´t need to do this trick. The problem is that two exact the same pictures will not produce the 3D effect.

So if someone knows how to setup a “master” player blueprint and a “slave” second player to have the second eye or even better, to create a splitscreen with other methods for just one player please let me know.

@The mods, i guess its not VR then but i thought it fits in because i need a simliar approach to simulate two eyes like the occulus does (?).

Thanks and greetings

Hm so finally i can approve it works, it is 3D (Side by Side effect). Objects can float out of the screen and so on, it looks amazing. The only downside is that the resolution is half of Full HD for each eye and i can´t set up the right aspect ratio for each eye so the final image is stretched and jittery. Hm. Just as i said, i don´t know if the debug stereo effect would solve that. I will try to find a solution, and ask again later.



How exactly did you get the red cyan test working? Would you mind laying it out step-by-step? I am trying to get stereoscopic 3D (with a 3D HDTV and glasses) working in UE4 and am having trouble. Thank you in advance for the help! :smiley:

Tridef 6.3 works for me. I have it set to output side-by-side to a 3DTV.

  • package the game
  • add the game .EXE to Tridef Ignition launcher and assign the generic profile
  • launch the game and enter full screen
  • disable Power 3D (Alt+Shift+F1 by default)
  • bring up the OSD (Num 0 by default, but I had to reassign the OSD keys - I think UE4 default keyboard controller has those keys bound)
  • switch left-right views
  • save the profile - as you add new UE4 games, you can start with this profile (you’ll still need to disable Power 3D the first time)

I was pleasantly surprised that it works with all the bells and whistles (everything on EPIC quality). Shadows and lighting can look very slightly off at times, so it’s not perfect. Unfortunately, I lose about 40% performance and my 2nd GPU is ignored.

(With 3D Vision, the second GPU is used and the performance doesn’t drop, but shadows and lighting are way off. Setting shadow quality to 0 makes it better, but you lose too much eye candy.)

@Melliferus , i used a Stereoscopic test program. Unfortunately can´t remember how it was called and its removed on my system. If you are interested in this, i will send you a pm with the link.

@joe.real thank you for your small tutorial. I will get a look on this

So i finally found out how to do the -emulatestereo.

Anyway, its easy, so please tell anyone about this if they are asking about this topic.
You pack your game and than you create a link to your packed .exe. Then you ad -emulatestereo in the line like shown into the picture. It might even work to set this in the command line at this point. And THIS is the command line that was talked about.
It was just misleading for me. And maybe for others too.


The main question is, if that 3DEffect works on the Side by Side S3D Beamer. I will test this out and tell you about the result.


I tested it out today, and it was 3D - but it was too much. The offset of the virtual eye pair seems to be to high. Is there a way to fix this ?
@Mods I don´t know if this topic has to be moved to another part of the forum from now on ?


Wow. When I tried this a month ago after reading JJ’s response, I was getting some D3D error on startup and it didn’t work. Just tried it again with a new build after reading your post, and it’s indeed working - I think.

The crazy FOV isn’t appropriate for the 3DTV. Normal “fov” console command doesn’t change it. I also didn’t get much sense of depth, so I too would like to know how depth and convergence, as well as FOV, can be adjusted. The console is not stereoized. Also, I have LPV enabled, and I think I’m getting indirect lighting rendered only in the left eye. The framerate is about the same as what I was getting with Tridef.

I have a DK2 on order, and I can’t wait to try this - with that FOV, I can only imagine how immersive it would be.

Hello dear…Is there any way to change side-by-side FOV…I am facing same problem.

Hello dear…Is there any way to change side-by-side FOV

Hello dear…Is there any way to change side-by-side FOV

I have trouble with the puzzle of " the resolution" and My game is stretched and jittery as well. Will you share your method with me? Thanks!!

I have trouble with the puzzle of " the resolution " and my game is stretched and jittery.will you share you method with me? thanks!!!