Download

Stereo on desktop always on in packaged builds

Hi there,

I have a VR project that now also needs to run as a standard desktop application. Shouldn’t be an issue, except that side by side stereo is stuck on in packaged builds. Things I’ve tried:

  • Disconnected HMD entirely before starting
  • vr.bEnableStereo 0, vr.bEnableHMD 0 (when querying these variables afterwards, they’re always still on 1), stereo off (now deprecated)
  • Start in VR is off, no command line arguments are being passed to the executable. -emulatestereo has never been used.
  • Updated to 4.18
  • Full rebuilds
  • Removed Packaged/<App>/Saved, to make sure any configs are cleared
  • Deactivated instanced stereo

The Vive plug-in is still enabled, since the project should also remain usable in VR - deactivating the plug-in would invalidate all related BP’s and cpp’s.

Any ideas on how to get Unreal to render a single viewport in the packaged build are greatly appreciated!

I am having the very same issue here. Did you happen to find a solution for this problem ? Even changing the pawn doesn’t help …

I did! You just have to disable the SimpleHMD plugin. It’s on by default, is not used by anything, and causes the issue.