Stereo Layers and gamma / texture compression question

I am doing instrument content with UMG for a VR game. To keep it crisp I am using get render target and stereo layers. See image. It works, I can get the UMG widget on screen and it is much crispier than with widget component.

One issue I am having however is that the content comes of dark. It clearly is a gamma / HDR vs SRGB issue. If I change textures to RGBA they come of in right shade but then UNG is not anymopre WYSISWYG.

Tutorials I have seen seem to bypass this very issue altogether. I am tired or dumb?

In the comparison picture below the Top/Dark is the version with widget being rendered to a stereo layer. And the one below is correct - straight from the 3D widget.

FRom what I gathered on the discord VR/AR chat:

|This is to be expected and I need to uncheck sRGB and accept that colors are not WYSIWYG

I am not fully convinced that this is kosher as AFAIK we are doing the linear/gamma workflow from the wrong end.


Widget component has a check box for gamma. Maybe everyone knew this. I didn’t. works nicely now.