Stereo Layer in 4.21.1 shows wrong colors

When rendering a Widget Component into a Stereo Layer the widget will show up in a - kind of - wrong color mode. It looks rather “multiplied” (in Photoshop terms) instead of “normal”.
Tested this also with assigning a texture directly into the Stereo Layer Texture Slot. This image is also rendered in a kind of “multiply” mode.

Is there a way to set the rendering mode of the Stereo Layer to “normal”, e.g. in an .INI-setting?

Would like to show you a screenshot, but the Stereo Layer isn’t mirrored to the monitor screen.

@tobra did you ever find the solution for this? noticing this still with 4.23 on the Rift

I had an issue like this and what i did is go into engine content and find the material called Widget3DPassThrough

and i added a power node and set its setting to different values till it looked right to me. my best look was a setting of 3 in the power node.

As we didn’t find a solution at that time, we didn’t go on with stereo layers (instead we made the widgets in the world bigger).

Maybe the solution of “frostic” will work for you?

Thank you for the input, Frostic. We skipped stereo layers completely since then - but great to see a possible solution, if we reintegrate stereo layers in the future :slight_smile:

just copy that file to your project then set the widget to use the one you copied to your project so it don’t edit your engine etc.
otherwise every time you update the engine the edit goes bye bye lol.