Download

SteamVR Vive floor height issues

Hey all, does anyone have any tips or tricks to getting the SteamVR room setup capture volume to match up with your world in the unreal editor? Documentation talks about using SetTrackingSpace to either standing or sitting. It looks like that node was replaced with SetTrackingOrigin in which the choices are Floor Level or Eye Level. I’m not able to find documentation on SetTrackingOrigin but it seems pretty self explanatory. I have a PlayerStart set in the world at what I want to be the floor height. When I have SetTrackingOrigin set to Floor Level, what should be the ground seems to be lowered in the world by about a meter. When it is set to Eye Level the height of the Unreal ground is almost right, but the tracking volume is in a completely different yaw orientation than the Unreal world. It seems to be setting things to be relative to either the origin or the hmd’s local rotation perhaps. Not sure what’s happening! Also of note -I’m currently using a first version dev kit vive with the just released 4.11 Unreal.

I’m noticing that the incorrect space offset is happening only when I am using my VR PlayerCharacter I created. I wonder if there are certain settings in there causing this. To make this character I left everything default. I guess I’ll have to keep playing around with settings/offsets in there.

Ok for those having the same issue, I found that my saved VRPlayerCharacter’s capsule collider needed to be scaled down from the default size. When starting in the editor it was pushing my height up to accommodate the capsule collider. It also was messing with what it thought was the height of the floor.

Excellent. I had the same problem. Thanks for the follow up patch!