Download

SteamVR Valve index Bindings having trouble - None responsive to Input settings

I’m having some issues with the Valve Index controllers in UE4.
I went to create a new input, and I got a warning message.
Screenshot 2021-03-12 232009.png

After I hit YES, all my bindings have changed, for every file I created. Even my backups of my files, so this is a global thing.
I then when to the SteamVR section in the preferences and tried to reinstall the standard bindings.

Screenshot 2021-03-05 234656.png

This gave me a strange looking Bindings with everything separated.

I tried recombining them

This broke everything.
Nothing worked after this.

I tried through trial and error and found several inputs that would respond.

This worked but I still have an issue. The top section has bindings in the same location, so I lose a direction for teleport.

Also…

The Input for Valve shows up in the Preference under Input:

Screenshot 2021-03-20 003521.png

But does not show up in the blueprints under input:

Screenshot 2021-03-15 171229.png

Can anyone help with this?

At the very least post an image of your bindings so I can copy what an stand binding looks like.

Please.:eek:

Accessing inputs directly from VR devices is no longer supported (apparently for OpenXR compliance), but it should still generate events for the actions themselves.

Do the actions still show up under Action Events in the Blueprint menu?

The actions show up, but they don’t do anything.
The blueprints also do not show any inputs for the valve.

What I have been doing is every time I create a new Input action, I go to the SteamVR page, and attach the controls I want in each action. Anything that shows up in read at the top as unmapped actions.

You may need to regenerate and reload everything after adding new actions, as in this guide:

Note that it will reset any manual bindings, so you’ll have to rebind anything it doesn’t set up right.

The direct VR device inputs in Blueprint are not supported anymore, but the action events are supposed to work. Also make sure the game window is focused when testing, otherwise the inputs get dropped.