Download

SteamVR starts itself when opening a project

Hi,

After latest SteamVR (SteamVR Beta Updated (1481245137)) update, SteamVR starts itself everytime I open a project. Did this happened to anyone else? I also posted this on SteamVr’s Bug Report page as well. Im using UE 4.14

This always happened. For me anyway.

I had it installed over 3 months. It never happend before for me. Its kinda annoying :slight_smile:

If you don’t plan on implementing it, I’d take a guess that removing the plugin wouldn’t launch steamvr. However if your project is using it, you’d want it open anyway hence why they open it.

Yes, you need to disable the plugin.

Separately: The Vive Updater will decide to run, and grab full-screen focus away from whatever I’m doing, at random times. It’s quite annoying. Lost an Overwatch match because of it …

I am working on projects that I will use HTC Vive. Removing plugin could solve the issue but I dont think it opens because my project is using it. Bc this happend after steam update. Additionally, you can only do VR Preview if you launch steam vr before you open Unreal Launcher. So there is no point in steam vr to open itself.

It is a bit old Topic but till this day it has not been solved? I found a recently simple solution for that.

Go to:

C:\Program Files\Epic Games\ YOUR UNREAL ENGINE VERSION \Engine\Plugins\Runtime\Steam\SteamVR\SteamVR.uplugin

open “SteamVR.uplugin” file with any txt editor in my case I did use Notepad++

and change

“EnabledByDefault” : true,

to

“EnabledByDefault” : false,

Thank you @Soulast , much appreciated

I know it’s a bit off-topic… but since you guys are also using the Vive and having some issues… maybe some of you knows what I am doing wrong.

I can’t figure out how I can launch the VR with my Vive, so that animations are also working like it’s working when using the game mode and when I press the PLAY button in the editor.

I created this short 2-minute video to explain and to see my see my problem:

What am I missing here?
I can’t get the VR to run the animation! :wink:

Or disable the plugin from within Unreal Editor: