SteamVR motion controlers inverted x/y axis

Hi!
I have worked in UE4 quite abit, but this is the first time devving with my Vive.
The tracking of the HMD works as expected, but the tracking of the controllers are inverted!

If i attach a cube and a sphere to the right and left hands, moving the controller to the right moves the cube/sphere to the left , pushing them away brings them closer!

I’ve checked all the scales and rotations, and all seem to be resting at the default 0’s.

Any idea how to fix this?

Tried to rotate pawn 180 degrees, tracking is closer but still off. Do i seriously have to manually finetune the rotation for my setup (and all the users in the future)? I’m also almost confident that the x and y scaling of the controllers are also off.

Surely i’m missing something, but i read over the documentation but its so outdated its almost unusable with half of it referencing parts that you don’t even have anymore!

This was easier in Unity even though I have ten times more experience with UE4…

im having the same issue with my pawn. When i was using the first person character i didnt have this issue, but with that my character was floating 2 feet above the ground and the only way to fix that was to use a pawn. Also with my pawn its duplicating my motion controller. So its like a mirror image of one controller but their axis is reversed. So frustrating.

No solution to this? I’m having the same problem.

Hello Warriorpoet897,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What version of the engine are you using?
  2. Does this happen in the latest version of the engine?
  3. Can you reproduce this issue in a clean project?
  4. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  5. Could you provide screen shots of any blueprints that may be involved with this issue?

Hello Warriorpoet897,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

I have already follow the toturial at https://docs.unrealengine.com/latest/INT/Platforms/VR/VRCameraRefactor/index.html#upgradingpreviousvrcamerasto4stop11
But it still not works . : (

Hello Nick,

Could you answer the questions that were asked of Warriorpoet897? This will help narrow down what issue it is that you are experiencing.