Steam VR Plugin does not generate mappings for Valve Index Thumbstick X/Y

I am setting up my axis mappings as shown below. When I run “Regenerate Action Manifest”, “Regenerate Controller Bindings”, and “Reload Action Manifest”, it does not update the manifest. I have a working Action mapping to the Index A button.

I have tried this on an empty project with the same results.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


In case anyone else with the same problem reads this the solution for me was:

Adding _X and _Y to the end of the names of the respective mappings seems to generate a proper vector2 and allows for it to be bound properly in SteamVR
for example:
Move_X and Move_Y


Shows in SteamVR as a vector2 action ‘Move’ which can now be bound to a thumbstick/joystick