Stationary not lighting a static mesh

I have many static meshes in my level; however, the main mesh (the asteroid in space which supports the other meshes) is not responding to stationary lights. Lights show up whilst I model, but not after the build. I’ve:

  • Changed the textures.
  • Deleted the Intermediate folder.
  • Tried lightmaps from 512 to 4096!
  • Dropped in another directional light.
  • Used a reflection capture.

However none of these worked. I suspect it may be because the scene is low on enviromental light (the ‘sun’ is below the model). Or that the mesh is too large – it’s about 1.5 km long and 1 km wide.

My computer specs are: Inel i7 7700, 4.2 ghz, 32gb RAM, NVIDEA Geoforce GTX 1060.

I’ve looked through other answers, and tried the solutuions there, none of which have worked.

Any help is hugely appreciated.

I’ve attached pics of pre and post light build:

Hello rusty1001

I think it’s because of your static mesh 1.5km x 1.5km is way too big to collect enough light data on lightmap. Do you have any chance to change it with terrain and try again? Also did you try to put “directional light” with “movable” setting?


Thanks for taking the time to reply. I’m sorry I’ve been slow to respond; however I was moving IRL. I tried with a directional light on movable and it made no difference.
The mesh cannot be replaced with terrain (unless someone knows how to drape terrain over an exisitng mesh).
What I will try is cutting up the mesh in Sketchup, and seeing if smaller chunks respond better. Onve I’ve done that I’ll post the results.