Stationary lights - dynamic shadow not showing

Ive had some trouble with stationary point lights and their dynamic shadows, sometimes
the dynamic light & shadow appear after a light bake and sometimes only the indirect part is shown.
I dont have too meny lights overlapping - Ive checked that. other issue is that few times my light is lighting multiple
static objects and only one of them is showing the dynamic part, others show only the indirect.
Ive tested this even with stationary spot lights and had similar bugs.
what am I doing wrong?

1 Like

Hi Kojala,

First you might want to go through your static meshes’ settings and make sure they have “Cast Shadows” on. You can extend the settings further and make sure that “Cast Dynamic Shadow” is checked. Also make sure that they are set to
static and not movable in the Transform section. Also check the light channel so that all of the meshes are on the same light channel as your light source. If that area is grayed out simply switch the asset to movable change the light channel and then switch it back to stationary.

If you still have problems, I’ve got some personal tips on how to troubleshoot this issue. You can start by eliminating all static and environment lighting in your map.

Go into the world settings, scroll down to the Lightmass section and do the following:

  1. Turn the Environment Intensity and Diffuse Boost to 0
  2. Then check at the bottom of Lightmass Settings, you will see a check box that says “Force No Precomputed Lighting”. Check this and rebuild lighting.

All of your dynamic lighting should still be intact. If you still have problems upload a screenshot of your issue!


In the pic there are two point lights and the walls are same mesh, the lamp shades are separate
meshes, as seen on the left, the light has its dynamic component showing on both wall and lamp shade meshes
but on the right the dynamic component is shown only on the lamp shade, wall has only the indirect component

I did the things that you had listed and I saw all the dynamic components of my lights correctly, but when I enabled them back, most of the lights did work, but some dont - one similar thing with the lights that dont work could be that they are the lowest in the whole scene, under the landscape etc.

Okay Kojala,

This could be a couple things. Your issue seems similar to the one listed in this troubleshooting guide: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

I’d also check your engine Scalability settings just to make sure your shadows aren’t on a low setting.

If you are still having issues just comment on this post and I will continue my investigation!


One thing that seemd to help is splitting the objects to multiple meshes, so that might be a lightmap size issue

No I dont think thats it, Ive had that but not anymore. as in my screenshot, the right lamp has no directional component shown, the wall has only the indirect component - in that unreal wiki link the directional is shown all the time, only the shadow is flickering on and off.

I got now all of of my lights working, just by splitting few objects and making some lightmaps a big larger

Is it possible to crack the software engine and bug the program allowing to put as many stationary and movable lights as you want?