Download

Static or dynamic lighting?

Hi

I have been working all day to find the right settings for the lighting.
I use the standard “SkySphereBlueprint”, i have directional lighting set to stationary, and skylight set to stationary.

But i can’t find a solution that allows my forest to look decent.

I have set my foliage (counts about 1K trees pr. level) to static, and casting static shadow only. Is has a lightmap resolution of 8.

I get the best looking results when the foliage is set to cast dynamic shadows. However i get the warning about performance hit if a big actor has dynamic shadows set to true.
I tried to set the light map up to 32, which produced better shading on the leaves, although still too dark, but with another warning telling that the lightmap size was large.
I’m building light at “high” quality settings

So is there something i am missing, or should i pick the lesser of two evils, regarding the errors, or is it maybe the material setup that is wrong?

0e85143b9a2ecd0dbb931fe5ea6c29e536100d70.jpeg
This is with static shadows

98fe0104ae28c0af840061f1afa663c39dbc1548.jpeg
This is with unbaked / dynamic shadows

fd89dcca21d98355f373e32af9e0923545c4a9c5.jpeg
This is the leaf material.

Hope theres a light magician out there, with a magic words for me :slight_smile:

Your lightmap resolution is too low. You might also need to check the lightmap UV’s on the trees to make sure they’re good.

The 2’nd UV channel is fine, and they are all unwrappes in a way that they don’t overlap.
If i increase the lightmap resolution, i get a warning about a large lightmap size. Should i just ignore that?

What you can do is increase the packed light and shadow map texture size, by default I think its set to 2048, try bumping that up to 4096. Located in World settings under lightmass

I’m surprised your getting that warning with such few trees, do you have other foliage in the scene?
Also, how many uv islands are in the 2nd uv channel?

What is your resolution? If you can’t get a good result without turning up the lightmap resolution to really high settings then your mesh is too complex and has too much surface area. Your trees look like they could probably get good results with something like 256 if you do the UV’s right. The landscape can be an issue if it’s very large.

Keep it on Lightmass: use cascaded shadow maps from your directional light so you get the benefits of dynamic shadows up close. Fill in those shadows with one stationary skylight for the entire level (brightness at 1 can work). Remember, the sky sphere is not the same thing as a skylight: the sky sphere is just the model used for the sky. But that model doesn’t actually cast light onto your environment: you need an actual skylight to do that. Raise the directional sun to a brightness of 6 or so. Change the ambient occlusion settings on your post process (that might have something to do with it). Increase the indirect lighting intensity until you get something that looks good (there’s actually a value in post process for this, but in the lightmass world settings you can also adjust the intensity of the indirect light when it’s baked for the entire world). Bake on High or Production: sometimes preview is a bit dim or duller than High lighting. From what I understand, Production is the same quality as High but with optimizations built in.

Post back if you still have issues.

Can you update the thread if/when you get this issue resolved?

Hi again.

Wow, ty for all the replies. Have been busy with work since my post, therefore no updates yet. I should be able to get back to the problem in the next few days, and will ofc. keep it updated :slight_smile:

its been so long without you my friend !! :frowning: